Port range can't be set 22:24

Asked by Matic on 2019-10-15

I can't set any port range with the colon.

The program clearly says it can be done if you set 22:24 into the text field, but the add button just greys out and nothing happens.

Question information

Language:
English Edit question
Status:
Solved
For:
Gufw Edit question
Assignee:
No assignee Edit question
Solved by:
costales
Solved:
2019-10-16
Last query:
2019-10-16
Last reply:
2019-10-16
costales (costales) said : #1

Hi,

The button grey is because you filled any other field not compatible
with a port range.
Could you send a screenshot or try to reset field to field until you
see the Add button enabled again? Then that is the incompatible field.

Best regards
--
Costales.

Matic (mkrmec) said : #2

When I enter 5001 only the add button is ok.
When I enter 5001:5194, it goes grey.

I tried many other ports, also 22:24 like in the tooltip, and it still goes grey.

I had it set at simple, allow, in, both, 5001:5194

Best costales (costales) said : #3

Hi,
Can't it "both", change for TCP or UDP ;)
Best regards.

Matic (mkrmec) said : #4

Yes, "both" in protocol was the problem... I had to add TCP and UDP separately.

Please note this in the tooltip or fix it. I consider this a bug.