How to install GUFW in Centos07

Asked by Matthew Sacco on 2018-12-27

May i ask a comprehensive guide (step by step) how to install GUFW in Centos7

I tried to install but failed. My ufw was working fine

Hoping for your response.

Question information

English Edit question
Gufw Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
costales (costales) said : #1

Hi Matthew,
I think it can not be possible. If you have ufw working, probably is some
different library.
Please, check the depedences from your Gufw version and in Centos:
Best regards

Matthew Sacco (mattsacc) said : #2

Currently this is my progress in attempting to install GUFW in Centos. Do you have suggestion to run this properly ???
or i need to install the right versions / prerequisite of GUFW in my current Centos version?


[root@localhost ~]# python -V
Python 3.5.1
[root@localhost ~]# cd /etc/gufw/gui-ufw-15.04.4/gufw
[root@localhost gufw]# ./
Traceback (most recent call last):
  File "./", line 19, in <module>
    from controller import Controller
  File "/etc/gufw/gui-ufw-15.04.4/gufw/", line 18, in <module>
    from model.frontend import Frontend
  File "/etc/gufw/gui-ufw-15.04.4/gufw/model/", line 18, in <module>
    from firewall import Firewall
ImportError: No module named 'firewall'
[root@localhost gufw]# systemctl status ufw.service
‚óŹ ufw.service - Uncomplicated firewall
   Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled; vendor preset: disabled)
   Active: active (exited) since Thu 2018-12-27 12:26:10 PST; 21h ago
     Docs: man:ufw(8)
 Main PID: 20275 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/ufw.service

Dec 27 12:26:10 localhost.localdomain systemd[1]: Starting Uncomplicated fire...
Dec 27 12:26:10 localhost.localdomain ufw-init[20275]: Firewall already start...
Dec 27 12:26:10 localhost.localdomain systemd[1]: Started Uncomplicated firew...
Hint: Some lines were ellipsized, use -l to show in full.
[root@localhost gufw]# cat /etc/redhat-release
CentOS Linux release 7.6.1810 (Core)

costales (costales) said : #3


I have no idea. Maybe you would have to update this file
 to the right python version?

/usr/lib/python3.5.1/site-packages/gufw/ ?

Best regards.

Matthew Sacco (mattsacc) said : #4

Thanks for the help im newbie in Linux/Centos environment thats why i exploring hehe. I think i know whats the problem why gufw in my Centos was not working, currently my Centos base environment was Minimal Install.

My colleague (Linux guy) told me that what type of installation i need to support GUFW in Centos [ Centos desktop environment (Gnome, KDE Plasma or Creative Workstation) ]

One more question i see installation steps how to install GUFW + UFW in Centos please validated if the instruction was correct?
I follow the instruction below "I can confirm this works on CentOS 7 for users who want to use gufw + ufw instead of firewalld"

Hoping again for your response :D

Best costales (costales) said : #5

Remember that Gufw has a deep integration with ufw and ufw has a deep
integration with Ubuntu/Debian systems.
That tutorial probably is for CentOS 6?
I never tried to run Gufw in CentOS, but if you have ufw running and Gufw
has all dependencies it should work :O
Best regards.

Matthew Sacco (mattsacc) said : #6

Thanks costales, that solved my question.

costales (costales) said : #7

I'm sorry I can't help you more with this. I never tried it and it's
complicated to run Gufw in CentOS :(
If it finally works, please let me know.
A hug and happy GNU year! :)