Blocking everything after starting machine

Asked by Samop on 2018-12-17

After installing Gufw, every time I start up my computer all network traffic is blocked until I open the Gufw gui and set the status to "On".

My machine runs Kubuntu 18.10.

Any ideas?

Regards

Sam

Question information

Language:
English Edit question
Status:
Solved
For:
Gufw Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
4 hours ago
Last query:
4 hours ago
Last reply:
2019-01-18
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Samop (samopn) said : #2

Surely someone has an idea of where I can start on this

Please

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Samop (samopn) said : #4

Please, someone give me something or somewhere to start...

Best Manfred Hampl (m-hampl) said : #5

This maybe is not helping at all, but I try to at least comment on your question.

1. Gufw is just the graphical interface helping to configure ufw (uncomplicated firewall). So if access is blocked, this is caused by ufw and not by gufw.

2. What is the status of ufw on your system?
What is the output of the command
sudo ufw status
immediately after booting, and what is the output of the same command after changing the status in gufw to "on"?

3. If you boot, and the network traffic is blocked, can you enable it with the command
sudo ufw enable
?

see also
https://wiki.ubuntu.com/UncomplicatedFirewall
http://manpages.ubuntu.com/manpages/cosmic/en/man8/ufw.8.html

Samop (samopn) said : #6

Thanks for your reply Manfred,

the ufw status was always "inactive" on booting and sudo ufw enable allowed the network traffic.

Interesting that the "discover" package manager didn't think that ufw was installed, even though I could query its status and enable it. Obviously the installation hadn't completed successfully.

So I did a
    sudo apt-get remove ufw
followed by
    sudo apt-get install ufw
    sudo apt-get install gufw

and it all works as expected now.

Thanks so much for giving me a starter on this.

Regards

Sam

Samop (samopn) said : #7

Thanks Manfred Hampl, that solved my question.