Gufw locks out the home network

Asked by Jeffery Lybbert on 2017-11-13

I built my first Linux PC with Mint 18.2. I added Gufw for security. When I turned it on, I was no longer able to connect to my Windows PC until I turned it off. I looked down the list but could not see the relevant firewall rule.

I appreciate your time in this. I love what I see in Linux thus far and plan to learn it and convert over. I refuse to windows 8 or 10.

Jeff

Question information

Language:
English Edit question
Status:
Open
For:
Gufw Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-14
Last reply:
2017-11-13
costales (costales) said : #1

Hi Jeffery,

The firewall by default will enable all out traffic, then you should
connect from Linux to Windows.
The opposite side (Windows > Linux) will not work, because you're blocking
all in traffic. In this case, you should open the port, but you have to
investigate which port ;)

A hug.

Jeffery Lybbert (jclybbert) said : #2

Thank you, costales.

I looked up the ports and found the following ports are associated with file sharing and server message block (SMB) communications:

Microsoft file sharing SMB: User Datagram Protocol (UDP) ports from 135 through 139 and Transmission Control Protocol (TCP) ports from 135 through 139.

Direct-hosted SMB traffic without a network basic input/output system (NetBIOS): port 445 (TCP and UPD).

I opened them but still nothing. I also modified the host file with the Microsoft pc's ip and nothing.

Can you help with this problem?

Provide an answer of your own, or ask Jeffery Lybbert for more information if necessary.

To post a message you must log in.