On enable, error in changing status

Asked by John Rose on 2008-09-18

I'm using Ubuntu Hardy.I've installed Gufw 0.20.0 on a desktop & a laptop. On the desktop, It's good. On the laptop, I'm not able to enable the firewall: it comes up with 'Error changing status firewall'. I've tried uninstalling & re-installing Gufw, but same happens. Can you tell me what's gone wrong and how I should correct it?

Question information

Language:
English Edit question
Status:
Solved
For:
Gufw Edit question
Assignee:
No assignee Edit question
Solved by:
costales
Solved:
2008-09-20
Last query:
2008-09-20
Last reply:
2008-09-20
Vadim Peretokin (vperetokin) said : #1

Can you go to File-Gufw log, and paste the log here?

John Rose (johnaaronrose) said : #2

The File - Gufw log menu option is grayed out. I've tried dmesg|grep ufw, but that shows nothing as do similar checks on syslog, kern.log.

costales (costales) said : #3

Hi!
I think is a bad instalation of ufw :O
https://bugs.launchpad.net/gui-ufw/+bug/251935
Can you verify the solutions?
Thanks a lot!

John Rose (johnaaronrose) said : #4

I've uninstalled ufw & re-installed as per the bug's instructions. However, this did not allow me to run gufw. So I uninstalled gufw and then re-installed by running debi installer on the downloaded package from the gufw website. Still get 'Error on status change'. I've tried changing the enabled=no to enabled=yes in /etc/gufw/gufw.conf. with no success. Any ideas?

costales (costales) said : #5

Hi!
Can you do this? (In terminal)
sudo ufw enable
sudo ufw disable

And say me the result of test ;)
Thanks!

John Rose (johnaaronrose) said : #6

Results are:

administrator@JohnLaptop:~$ sudo ufw enable
ERROR: uid is 0 but '/usr' is owned by 1000
administrator@JohnLaptop:~$ sudo ufw disable
ERROR: uid is 0 but '/usr' is owned by 1000
administrator@JohnLaptop:~$

PS root's user id is 0; administrator's user id is 1000.

Best costales (costales) said : #7

Hi!
Is a problem of owner of /usr ;)
Run this command in terminal:
sudo chown root.root /usr
If change the folder '/usr' in other error, change it in the command ;)
Please, say us the result :D
Thanks!

John Rose (johnaaronrose) said : #8

Thanks Marcos Alvarez Costales, that solved my question.

costales (costales) said : #9

Thanks you by use GNU/Linux ;D