gufw menu=>help=>doc or get help online not working

Asked by anteas on 2016-05-16

Hello, I use LM 17.3 and 14.04.2 LTS Gufw.
when I click on the tab and help "documentation" or "get help online" or other options in this tab except "about" anything that works. As soon as I turn the UFW VLC video cut is normal but I rather nice to add rules allow nothing allows VLC has to connect.
I followed this documentation:
https://doc.ubuntu-fr.org/gufw
but I can not.
to please help.

Question information

Language:
English Edit question
Status:
Answered
For:
Gufw Edit question
Assignee:
No assignee Edit question
Last query:
2016-05-16
Last reply:
2016-05-17
costales (costales) said : #1

Hi anteas,
It is working for me. So weird :O
You have the documentation here:
https://help.ubuntu.com/community/Gufw
A hug.

anteas (anteas-) said : #2

such a response is not nothing. I can also send you links but it does not change the fact that no option in Help menu except "about" does not work! You find it normal?

anteas (anteas-) said : #3

if you want I can make a video

costales (costales) said : #4

Please, run Gufw from the shell with:
$ gufw

And paste here the exit.

anteas (anteas-) said : #5

from shell? Are you mean cmd line?
when I'm run gufw from cmd line I get this :

java version "1.7.0_101"
OpenJDK Runtime Environment (IcedTea 2.6.6) (7u101-2.6.6-0ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode)

anteas (anteas-) said : #6

I just come see the Help menu works if I execute the gufw from the command line

costales (costales) said : #7

Please, paste me everything, from open to start. I don't see the command.

anteas (anteas-) said : #8

Nevertheless, no rules will not work. If I put home profile and incoming and outgoing sets I refuse there is nothing that comes out mode and no rules do not allow me to assign a exeption has application.
When I tested gufw under virtual box installed in LM everything worked perfectly. I do not understand :(

anteas (anteas-) said : #9

I open the cmd line as root and I type gufw & I get this :

java version "1.7.0_101"
OpenJDK Runtime Environment (IcedTea 2.6.6) (7u101-2.6.6-0ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode)

there is nothing else useful and I apologize if I keep to myself the name of my machine and my login

anteas (anteas-) said : #10

If I put a new rule:

policy : allow
direction : booth
application : vlc udp stream

I get this in cmd line :

(gufw.py:10813): Gdk-CRITICAL **: gdk_device_ungrab: assertion 'GDK_IS_DEVICE (device)' failed

(gufw.py:10813): Gtk-CRITICAL **: gtk_device_grab_remove: assertion 'GDK_IS_DEVICE (device)' failed

(gufw.py:10813): Gdk-CRITICAL **: gdk_device_ungrab: assertion 'GDK_IS_DEVICE (device)' failed

(gufw.py:10813): Gtk-CRITICAL **: gtk_device_grab_remove: assertion 'GDK_IS_DEVICE (device)' failed

costales (costales) said : #11

Please, paste here everything from the Terminal ;)
--
Sent using Dekko from my Ubuntu device

anteas (anteas-) said : #12

the only information missing is the machine name and user name so you do not need to know to identify the problem ;)

costales (costales) said : #13

You could be running as root, and then I would see that.

I think you're using a newer version of Gufw for another distro (?).

anteas (anteas-) said : #14

the version of my ufw is not described above if: 14.04.2 LTS is and I am running under LM 17.3 KDE x64
The gufw I installed using a default integrated software manager in my linux mint

anteas (anteas-) said : #15

correction :

the version of my ufw is described above and is: 14.04.2 LTS and I am running under LM 17.3 KDE x64
The gufw I installed using a default integrated software manager in my linux mint

costales (costales) said : #16

LM 17.3 KDE, uhm... probably you'll need a GNOME library then for open
menu links (?).
But I don't know which :( I'm so sorry.
--
Sent using Dekko from my Ubuntu device

On Tue, May 17, 2016 at 9:22 PM, anteas
<email address hidden> wrote:
> Question #293791 on Gufw changed:
> https://answers.launchpad.net/gui-ufw/+question/293791
>
> anteas posted a new comment:
> correction :
>
> the version of my ufw is described above and is: 14.04.2 LTS and I am running under LM 17.3 KDE x64
> The gufw I installed using a default integrated software manager in my linux mint
>
> --
> You received this question notification because you are an answer
> contact for Gufw.

anteas (anteas-) said : #17

the real problem is that no rules only allows applications to connect to the internet if the gufw is running mode and the input and output is deny.

Can you give me an example of the parameters to apply a rule that allows firefox has access to the internet?

thx

costales (costales) said : #18

You should look the Report window about ports. Every user is a world :)
--
Sent using Dekko from my Ubuntu device

anteas (anteas-) said : #19

is there anyone here who can help me solve my problem without writing useless comments?

thx :)

anteas (anteas-) said : #20

If you put the gufw ON mode and entering and exiting refuse we can still create rules, but what's the point if it does not work?

ex:

I'm in fashion gufw ON incoming / deny ougoing
and I wish to enable Firefox to connect so I'll add a rule.

Name: Firefox
Policy: allow
management: both
protocol: booth
Service: http

after applying this rule firefox has still can not connect.

But if it is upside down:

gufw in ON mode incoming / outgoing allow and I add the rule:

Name: Firefox
Policy: deny
management: both
protocol: booth
Service: http

then it works because all the applications can connect except Firefox,

Tell me please logic.

Or how to allow an application to connect if the mode is gufw incoming / outgoing deny

anteas (anteas-) said : #21

I feel that everyone he can do it but nobody wants to help.
Links to documentation ufw I can send you also, but I would have appreciated if someone be able to guide me, poor fool

anteas (anteas-) said : #22

and although eventually I think I should rephrase that.
On a french forum I had a clever answer.
Mod gufw in / out to denny all has firefox to connect must use the door 443. It works very well but the problem is that I do not see any related information in the report and listening so I ask myself how to target an application that is not in the list of applications?
For example VLC he is not in the list of applications but there is in the list of rules. I note with sadness that it is useless because none of its rules does not allow VLC to connect.
Do you have an idea please?
thank you

Can you help with this problem?

Provide an answer of your own, or ask anteas for more information if necessary.

To post a message you must log in.