routed option can not be activated

Asked by RobertRobert on 2014-10-31

Hi,

I want to use (g)ufw to block all traffic on all interfaces BUT ppp0 (which is my VPN)
I tried to activate the routed option like explained in the documentation:

I uncommended /etc/ufw/sysctl.conf:
    net/ipv4/ip_forward=1
    net/ipv6/conf/default/forwarding=1
    net/ipv6/conf/all/forwarding=1

And I did sudo ufw reload but no arrow around the shield.

I also tried "DEFAULT_FORWARD_POLICY="ACCEPT"" in "/etc/default/ufw" and "sudo service ufw restart"
(because of: http://stephen.rees-carter.net/thought/how-to-enable-ip-forwarding-with-ufw )

I did reboots in between the steps. No arrow around the shield and the "interface" option in the "advanced" tab stay grey.
What can I do?

Thank you!

Ubuntu14.04 LTS
gufw 14.04.2-0ubuntu1.1

Question information

Language:
English Edit question
Status:
Solved
For:
Gufw Edit question
Assignee:
No assignee Edit question
Solved by:
costales
Solved:
2014-10-31
Last query:
2014-10-31
Last reply:
2014-10-31
Best costales (costales) said : #1

Hi :)
https://help.ubuntu.com/community/Gufw#Enable_IP_forwarding
You need to use Gufw 14.10, Gufw 14.04 hasn't the IP forwarding.

Download the official package from here:
http://mirrors.kernel.org/ubuntu/pool/universe/g/gui-ufw/gufw_14.10.1-0ubuntu2_all.deb
and install:
sudo dpkg -i gufw_14.10.1-0ubuntu2_all.deb

Don't worry, I development Gufw 14.10 in Ubuntu 14.04, then it has to work.

Could you confirm me if all works? :)
Best regards!

RobertRobert (robertzufall) said : #2

Thanks costales, that solved my question.

RobertRobert (robertzufall) said : #3

Yes, the arrow is there now. I'll run some tests later. Thanks!

costales (costales) said : #4

You're welcome! :) It was a pleasure!