GUFW 9.10.2 missing the "DENY button for outgoing traffic"

Asked by Daniel Orum on 2013-11-02

Hi.

I wanted to follow the instructions here:
https://airvpn.org/topic/5586-prevent-leaks-with-linux-firestarter-also-stop-traffic-when-vpn-drops/#entry5642

But my version of GUFW (9.10.2) is missing a button for "Denying all outgoing traffic". Here is a screenshot:
[IMG]http://imageshack.us/a/img21/9837/g6cl.jpg[/IMG]

 Is there another way, i can work around this missing feature, because i am running OMV (squeeze) and there isnt any newer version for my system.

Thanks for your time.

Question information

Language:
English Edit question
Status:
Answered
For:
Gufw Edit question
Assignee:
No assignee Edit question
Last query:
2013-11-02
Last reply:
2013-11-02
costales (costales) said : #1

Hi :)
Your Gufw version is really older (and deprecated).
What is OMV? :) Which is your distro and version?
Best regards!

Daniel Orum (danielorum) said : #2

Wow, quick response.

OMV is Openmediavault. It is a Debian based NAS operating system running squeeze: http://openmediavault.org

 But i dont know how to check the version number. I really want to be able to use GUFW because it's so simple and i can unserstand it. What are my options here? :)

costales (costales) said : #3

Could you run this command in the Terminal?
sudo ufw version
And paste here the exit.
Thanks in advance!

costales (costales) said : #4

And... How did you install Gufw? :O From the Openmediavault repositories? :)

Daniel Orum (danielorum) said : #5

Forgive me, for not being specific enough:

I installed ufw by:

sudo apt-get install ufw

and gufw:

sudo apt-get install gufw

"sudo ufw version" gives me:

ufw 0.29.3-1
Copyright 2008-2009 Canonical Ltd.

costales (costales) said : #6

Uhm...
ufw 0.29.3 is deprecated. Your Gufw version is deprecated too.

Do you have the last release of Openmediavault? If the answer is yes, could you try enabling the Openmediavault backports repositories? Maybe you could upgrade to a newer ufw & Gufw version.

If you can't upgrade to a newer version, maybe you could install from the newer Ubuntu repositories, but I can't tell you if this will work:
http://packages.ubuntu.com/precise/ufw
http://packages.ubuntu.com/precise/gufw
Click in "Architecture All" and download the .deb file. Install from the Terminal with:
sudo dpkg -i your_file.deb

Good luck!

costales (costales) said : #9

sorry, the rm command has to be:
rm gufw_12.04.1-0ubuntu1_all.deb

Daniel Orum (danielorum) said : #10

ok. thanks for your help, but it dosent work. I get this:

root@test:~# sudo dpkg -i gufw_12.04.1-0ubuntu1_all.deb
(Reading database ... 40510 files and directories currently installed.)
Preparing to replace gufw 13.10.2-0ubuntu1 (using gufw_12.04.1-0ubuntu1_all.deb) ...
Unpacking replacement gufw ...
dpkg: warning: unable to delete old directory '/etc/gufw/app_profiles': Directory not empty
dpkg: warning: unable to delete old directory '/etc/gufw': Directory not empty
dpkg: dependency problems prevent configuration of gufw:
 gufw depends on python2.7; however:
  Package python2.7 is not installed.
 gufw depends on python (>= 2.7.1-0ubuntu2); however:
  Version of python on system is 2.6.6-3+squeeze7.
 gufw depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not installed.
 gufw depends on gir1.2-polkit-1.0; however:
  Package gir1.2-polkit-1.0 is not installed.
 gufw depends on notify-osd | notification-daemon; however:
  Package notify-osd is not installed.
  Package notification-daemon is not installed.
 gufw depends on python-dbus; however:
  Package python-dbus is not installed.
dpkg: error processing gufw (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
 gufw
root@test:~#

And with the 13.10.2 version:

root@test:~# sudo dpkg -i gufw_13.10.2-0ubuntu1_all.deb
(Reading database ... 40308 files and directories currently installed.)
Preparing to replace gufw 9.10.2-1 (using gufw_13.10.2-0ubuntu1_all.deb) ...
Unpacking replacement gufw ...
dpkg: dependency problems prevent configuration of gufw:
 gufw depends on python (>= 2.7.1-0ubuntu2); however:
  Version of python on system is 2.6.6-3+squeeze7.
 gufw depends on ufw (>= 0.31.1); however:
  Version of ufw on system is 0.29.3-1.
 gufw depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not installed.
 gufw depends on gir1.2-webkit-3.0; however:
  Package gir1.2-webkit-3.0 is not installed.
dpkg: error processing gufw (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
 gufw

So i guess im out of luck. But thanks for trying anyways.. i think GUFW is really cool, but perhaps i should try another application instead.. :(

costales (costales) said : #11

Don't worry, it was a pleasure.
I'm so sorry.

In other way, I think your distro is an older version:
http://sourceforge.net/projects/openmediavault/files/
The last is from this year. I recommend you to have not a deprecated system :O

Best regards!

Can you help with this problem?

Provide an answer of your own, or ask Daniel Orum for more information if necessary.

To post a message you must log in.