Firewall dsabled

Asked by Andrew Norton on 2012-02-05

Hi Linux community,
I have just migrated from XP to Mint.
I am no expert!
The firewall is disabled by default so I enable it then close the window.
But when I check again it is disabled again.The only way I have found to keep it enabled is by just minimising the window.
Is this normal?
Sorry if this turns out to be a really stupid question!
Regards, Andy

Question information

Language:
English Edit question
Status:
Solved
For:
Gufw Edit question
Assignee:
No assignee Edit question
Solved by:
Andrew Norton
Solved:
2012-02-06
Last query:
2012-02-06
Last reply:
2012-02-06
costales (costales) said : #1

Hi and welcome to board! :D
Could you search the Terminal application and run this commands?
sudo ufw status
sudo ufw enable
sudo ufw status
Please, put here the exit command.

Andrew Norton (andynrtn856) said : #2

Hi Costales,
I've already tried your advice after checking the Mint forum.
Still it turns off after I close the window.

costales (costales) said : #3

But could you paste here the exit commands? :) Thanks

Andrew Norton (andynrtn856) said : #4

andrew@linuxmint ~ $ sudo ufw status
[sudo] password for andrew:
Status: active
andrew@linuxmint ~ $ sudo ufw enable
Firewall is active and enabled on system startup
andrew@linuxmint ~ $ sudo ufw status
Status: active
andrew@linuxmint ~ $

costales (costales) said : #5

Uhm...
I think all it's working right. Could your answer me, please?
You open the firewall, the shield is in a grey color? Then if you click on the lock icon, you enter the password and the shield changes (to red/green/blue color?)?

Andrew Norton (andynrtn856) said : #6

Hi Costales,
Yes.
I then close the window.But if I open it to check again it has gone back to grey.
According to your answer in Question #98643 this may be normal.
[
Costales (costales) said on 2011-06-12: #4

@Sage5: Yes, it's normal ;) It's a security feature, only an admin user can run Gufw and 'see' the rules ;)
Until you enter the password, you can't see any rule or the state of firewall ;)
Best regards!
                          ]
Aithough that question was about Ubuntu , I've just realised.
Regards, Andy

costales (costales) said : #7

Yes :) I think this answer could help you:
https://answers.launchpad.net/gui-ufw/+question/40757
Remember this wiki too :) https://help.ubuntu.com/community/Gufw
Best regards! :)

Andrew Norton (andynrtn856) said : #8

Thanks Costales