Gufw and ftp

Asked by jorge@sol.at on 2010-05-27

Hi,

Yesterday I've installed Gufw to get a better overview of my ubuntu 8.04.4 LTS ufw settings. Previously I installed the xfce desktop, also.

My problem was, that the ufw settings for ftp (port 21 and the port range set for passive) were not functioning and I couldn't reach my ftp server without disabling ufw. I set then the preconfigured ftp settings of Gufw, and voilá, I could log on the ftp server.

Now, the problem is, that if Gufw is not running, I can not reach my ftp server. How can be that possible? I thought that what I was setting up in Gufw was taked automatically from the ufw setup and therefore from iptables. I'm a little confused.

Thank you

jorge

Question information

Language:
English Edit question
Status:
Solved
For:
Gufw Edit question
Assignee:
No assignee Edit question
Solved by:
jorge@sol.at
Solved:
2010-05-27
Last query:
2010-05-27
Last reply:
2010-05-27
costales (costales) said : #1

Hi Jorge!
I had 3 bugs about this issue in the past... It is a strange behavior, which occurs rarely in Ubuntu 8.04 & 8.10 :S
I can't reproduce the error in my computer in the past, and I haven't a solution for this :( sorry very much.
Try to purge ufw & gufw:
sudo apt-get purge ufw gufw
sudo apt-get install ufw gufw
One point: You must use Gufw 0.20.7 for Ubuntu 8.04 ;) https://launchpad.net/gui-ufw/+download
Best regards.

jorge@sol.at (jorge-sol) said : #2

Hi Marcos,

thank you for your fast answer. It's a little confusing (and I do have the Gufw 0.20.7). The only thing that Gufw did, was to add a tcp 21 allow rule, and then ftp was functioning. But I had already one allow rule for port 21 for tcp and udp.

Well, I purged and began to add the rules manually with ufw. It seems to be functioning now, forwarding (it's also a gateway server) and ftp are running now. Also I began to write a little script to make the blackhole routing necessary to get rid of the chinese plague attacking my servers. I can administrate it with list of offending ip ranges in a file and make the routing at start.

Thank you Marcos for the help, but I think I stay by ufw in old fashion now.

j o r g e

costales (costales) said : #3

OK Jorge ;) Really I don't undertand this issue, Gufw hasn't any code for this issue... ?:O I think is a set of strange situations in one computer, and I need reproduce for fix... I use Xubuntu 8.04 with Gufw 0.20.7 perfectly as home server, and I haven't this issue.
I'm so sorry! Best regards.
One point: for some simple rules, you can use Gufw 10.04 in Ubuntu 10.04 and get the script for a server in /File/Gufw Log menu.

jorge@sol.at (jorge-sol) said : #4

Hi Marcos,

you don't need to worry. I think the problem is ufw not your program. I only prefer to do the work directly on the ufw because I'm not sure if I'm keeping it in desktop modus and because I have already some scripts for ufw.

Thank you again (and I'm setting the item as solved)

jorgeY