Dependancy of pdftk

Asked by Pieter J. Kersten (EduSense BV) on 2015-09-25

As you may have noticed (or not), pdftk is no longer installed on at least Fedora (since 21). As the import/export function depends on it, its functionality is no longer available. Are there plans to change to similar tools as pdftk? If so, can you shed some light on the time frame?

TIA

Question information

Language:
English Edit question
Status:
Solved
For:
Getting Things GNOME! Edit question
Assignee:
No assignee Edit question
Solved by:
Pieter J. Kersten (EduSense BV)
Solved:
2015-10-21
Last query:
2015-10-21
Last reply:
2015-10-17
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Anyone?

Izidor Matušov (izidor) said : #3

Hi,

GTG is using pdftk only here: https://github.com/getting-things-gnome/gtg/blob/master/GTG/plugins/export/export_templates/script_pocketmod

It is used to create pocket mod (http://www.pocketmod.com/)

Unfortunatelly, the plugin is not actively maintained and thus we don't have any concrete plan.

Ah, I understand. This plugin is still useful for im/export, even without pdftk. As things are, it won't activate unless it 'sees' pdftk. Without maintainers, I will deactivate this dependancy myself.

Thanks for the info.

Izidor Matušov (izidor) said : #5

You can remove that check by removing / commenting out the following lines in your installation: https://github.com/getting-things-gnome/gtg/blob/c079976f9b5befb2828eab321938876a71deaf97/GTG/plugins/export/export.py#L34-L38