What is the status of the evolution plugin? How can one install it?

Asked by Ankur Sinha on 2013-11-30

Hi,

I'm the gtg maintainer for Fedora. Could you tell me what the status of the gtg-evolution plugin is please? Is it functional? I've updated the Fedora gtg version to 0.3.1, but no evolution plugin shows in the plugin list. There is an "send as email" plugin, but not one that will sync evolution's tasks with gtg.

Thanks,
Ankur

Question information

Language:
English Edit question
Status:
Solved
For:
Getting Things GNOME! Edit question
Assignee:
No assignee Edit question
Solved by:
Parin Porecha
Solved:
2013-12-20
Last query:
2013-12-20
Last reply:
2013-12-19
Parin Porecha (parinporecha) said : #1

Hi,

There isn't a plugin for evolution sync. It is a backend actually.
I haven't used it, so I am not aware of it's current state, but the reason it's not showing up might be because it's python bindings aren't installed on the computer you are checking on.

If you run GTG via command line, do you get a traceback like this -
2013-11-30 10:09:57,964 - WARNING - __init__:__init__:74 - Backend backend_evolution could not be loaded: No module named evolution
?
If yes, then GTG has disabled the backend.

Ankur Sinha (sanjay-ankur) said : #2

Ah! Yeah, seems like evolution isn't the only backend that is disabled:

[asinha@ankur-laptop ~]$ gtg
2013-11-30 15:55:03,376 - WARNING - __init__:__init__:74 - Backend backend_rtm could not be loaded: No module named dateutil.tz
2013-11-30 15:55:03,384 - WARNING - __init__:__init__:74 - Backend backend_mantis could not be loaded: No module named suds.client
2013-11-30 15:55:03,393 - WARNING - __init__:__init__:74 - Backend backend_evolution could not be loaded: No module named evolution
2013-11-30 15:55:03,398 - WARNING - __init__:__init__:74 - Backend backend_launchpad could not be loaded: No module named launchpadlib.launchpad

I'll go figure out what packages install these and add a readme or something to tell users that these can be installed.
Thanks for the quick answer. I'll close the question once I figured the packages out, so others looking for the same info might gain from it.

Thanks,
Warm regards,
Ankur

Parin Porecha (parinporecha) said : #3

The README in the tarball has all the dependencies for each backend and plugin listed.

The packages listed there are debian ones. Fedora might have different names for them, but it can surely help you in the process.

Ankur Sinha (sanjay-ankur) said : #4

I'll have a look at the package list.

I couldn't find evolution bindings in the Fedora repos. The debian package version is 2.32, but evolution in Fedora is 3.10, so I'm not really sure what's going on. I've asked on the Fedora desktop list though, and will update the question accordingly.

http://packages.debian.org/wheezy/python-evolution

https://lists.fedoraproject.org/pipermail/desktop/2013-November/008473.html

Thanks,
Ankur

Ankur Sinha (sanjay-ankur) said : #5

This is the response from a developer on the desktop mailing list:

"If you look at the changelog from the package you'll see that the
evolution extension has been dropped. This is because the
gnome-python2-desktop bindings are written with gtk2 and evolution
needs gtk3. For all gtk3 apps you'll need to use the automatically
generated gobject-introspection bindings which evolution-data-server.

So ultimately just packaging it up won't fix the problem, you'll need
to have gtk3 support for it.

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=465567"

Here is the referred Changelog entry:

"* Sat Jul 28 2012 Kalev Lember <email address hidden> - 2.32.0-12
- Obsolete the dropped gnome-python2-evolution subpackage

* Fri Jul 27 2012 Colin Walters <email address hidden> - 2.32.0-11
- Drop evolution bindings; they don't build against the latest EDS"

Does this mean the gtg evolution backend needs to be updated to use the new evolution bindings? Should I file a separate bug for this?

Thanks again,
Warm regards,
Ankur

Best Parin Porecha (parinporecha) said : #6

Yes, this means that the evolution backend needs to be updated.
I checked the backend code in the gtk3 port of GTG. It also uses the same python bindings as before.

There are a few bugs reported which are related to this (though not specifically the gtk3 need) -
https://bugs.launchpad.net/gtg/+bug/936183
https://bugs.launchpad.net/gtg/+bug/931539

Since you have more information than the bug reports filed already,
it'll be better if you file a separate bug for this.
I'll mark the rest as duplicate.

Ankur Sinha (sanjay-ankur) said : #7

Issue not solved, but a bug has been reported. Thanks for your responses Parin.

Ankur Sinha (sanjay-ankur) said : #8

Thanks Parin Porecha, that solved my question.