GTG no longer starts

Asked by Desertfish on 2012-07-01

Installed GTG in Ubuntu 10.04 - it worked fine for a week or two, then one day it wouldn't start. I checked synaptic package manager in case I needed an update - nothing showed up. I uninstalled GTG then reinstalled, still no luck. I started it via the terminal and got this message:
Traceback (most recent call last):
  File "/usr/bin/gtg", line 52, in <module>
    sys.exit(GTG.gtg.main(options, args))
  File "/usr/share/gtg/GTG/gtg.py", line 107, in main
    config = CoreConfig()
  File "/usr/share/gtg/GTG/core/__init__.py", line 86, in __init__
    self.conf_dict = ConfigObj(self.CONF_DIR + self.CONF_FILE)
  File "/usr/lib/pymodules/python2.6/configobj.py", line 1238, in __init__
    self._load(infile, configspec)
  File "/usr/lib/pymodules/python2.6/configobj.py", line 1328, in _load
    raise error
configobj.ConfigObjError: Parsing failed with several errors.
First error at line 3.

What should I try next, please?

Question information

Language:
English Edit question
Status:
Answered
For:
Getting Things GNOME! Edit question
Assignee:
No assignee Edit question
Last query:
2012-07-02
Last reply:
2012-07-03
Izidor Matušov (izidor) said : #1

Hi,

something bad happend to GTG configuration files and they are not readable. They are stored in ~/.config/gtg. If you remove it, GTG starts again but you lose a bit of your configuration (enabled plugin, is the tagsidebar showed or not?, etc.)

The command

mv ~/.config/gtg/gtg.conf ~/.config/gtg/gtg.conf.bak

should solve your problem.

Desertfish (desertfish) said : #2

Thanks for that - I tried it, now I'm getting a different error message:

Error parsing XML file /home/jon/.local/share/gtg/projects.xml: not well-formed (invalid token): line 1, column 1

Is this the same thing, or something different? Is GTG becoming sentient?

Izidor Matušov (izidor) said : #3

Hi,

I am sorry for that inconvenience. GTG must crushed or didn't end properly when you turned your computer off and malformed your data. GTG backups your data in ~/local/share/gtg, try to find a sane backup and restore it. For more information read https://live.gnome.org/gtg/FAQ

The current development version of GTG does it instead of you. It shouldn't happen in next versions of GTG

Can you help with this problem?

Provide an answer of your own, or ask Desertfish for more information if necessary.

To post a message you must log in.