Grub-customizer give error

Asked by p33r81 on 2018-02-01

messing with grub-customizer and now it gives error: "sudo update-grub
/usr/sbin/grub-mkconfig: 37: /etc/default/grub: Syntax error: EOF in backquote substitution"
at launch. what to do?

thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
p33r81
Solved:
2018-02-02
Last query:
2018-02-02
Last reply:
2018-02-02

Please show the contents of /etc/default/grub

p33r81 (p33r) said : #2

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'
GRUB_GFXPAYLOAD_LINUX="keep"
GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="
video="uvesafb:mode_option=1024x768-24,mtrr=3,scroll=ywrap"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"
GRUB_GFXMODE="1920x1080"
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

There's a syntax error:
GRUB_CMDLINE_LINUX_DEFAULT="

But I don't think it's from Grub Customizer. Could it have existed before?

Edit the file manually please. Change this line to GRUB_CMDLINE_LINUX_DEFAULT="quiet". Then the problem should be fixed.

p33r81 (p33r) said : #4

that was the problem! it did start to get problems first with grub customizer..

thanks very much for your help!