Can't change appeaarance colors

Asked by Preston on 2015-12-17

I'm using Linux Mint Cinnamon 17.3 (64 bit) and dual booting with Windows 10. Grub Customizer works great. Thanks for providing it. However, I cannot get the font and background colors to change on the appearance tab. I make the changes and save them. They stay changed in Grub Customizer, but nothing happens on my boot menu. I am not using a background image (I want a solid background).

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Last query:
2016-05-05
Last reply:
2016-05-21
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Sry, for answering so late.

You cannot use custom background colors without setting a background image. The configuration written by grub customizer isn't used if no background image set. This is the behavior of 05_debian_theme. I cannot change it (or at least don't want to manipulate the script). Grub customizer informs about this problem (background required to use custom colors).

Preston (preston-k) said : #3

Thanks for the reply. Since I submitted that question I suspected that I needed to use an image. so I set an image. But I still can't get the font and background colors to work. I'm using a JPEG image file with about the number of pixels on my display. Are there special requirements for the image? Thanks for your help on this.

There are two possible problems:

- The image path contains spaces
- the image itself is not compatible (I don't know the exact parameters here)

Preston (preston-k) said : #5

- I've checked the image path, and it has no spaces.
- I tried another image file, but I still can't change the font or background colors (they change beautufuly in Grub Customizer but not on the actual boot screen).

Preston (preston-k) said : #6

I experimented with several image file formats (.jpg, .png, . eps, . bmp, etc) and different image sizes with no luck. I couldn't get any of them to apply the font or background colors.

Run `sudo update-grub` on command line and search the output for something like "Found background image". If this message os shown, then the configuration is correct. In this case I cannot tell you anything more. In the other case it may be a problem of grub customizer.

Preston (preston-k) said : #8

Hi Dan,

I ran it. The image was found, so I guess that we are finished. However,
I'm attaching a screen shot of the session, because it is interesting.
Two other images were found after mine; do they supersede and thus
negate mine? There is a second set of found images, which doesn't
include mine; does it take precedence?

Please let me know if this leads to any new insight.

-- Preston

On 1/20/2016 5:52 AM, Daniel Richter wrote:
> Your question #279393 on Grub Customizer changed:
> https://answers.launchpad.net/grub-customizer/+question/279393
>
> Status: Open => Answered
>
> Daniel Richter proposed the following answer:
> Run `sudo update-grub` on command line and search the output for
> something like "Found background image". If this message os shown, then
> the configuration is correct. In this case I cannot tell you anything
> more. In the other case it may be a problem of grub customizer.
>

Launchpad Janitor (janitor) said : #9

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Preston (preston-k) said : #10

Please keep it open. On Jan 20 I attached a screen shot and asked for
observations about it. I still hope to fix the problem.

-- Preston

On 2/5/2016 12:38 AM, Launchpad Janitor wrote:
> Your question #279393 on Grub Customizer changed:
> https://answers.launchpad.net/grub-customizer/+question/279393
>
> Status: Open => Expired
>
> Launchpad Janitor expired the question:
> This question was expired because it remained in the 'Open' state
> without activity for the last 15 days.
>

Launchpad Janitor (janitor) said : #11

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

there are no screenshots…

The reason to your problem may be that Linux Mint places an image to /boot/grub and prefers it over the configured image. So it has to be removed.

Preston (preston-k) said : #13

Thanks for the info. There are no images in my /boot/grub, and I just
did a fresh installation of Linux Mint and it didn't have images in its
/boot/grub either.

But I am now getting the colored text that I wanted. I got it to work by
using an actual photo for the JPEG file. Before, since I really wanted a
plain black background, I created a JPEG file that was a small black
rectangle (200 x 300 pixels). Now I'm using a photo (700 x 1000 pixels)
that happens to have mostly black in the upper left corner, where the
boot options are located.

This resolves it for me. Thanks for your help and interest.

Preston

On 4/21/2016 12:27 PM, Daniel Richter wrote:
> Your question #279393 on Grub Customizer changed:
> https://answers.launchpad.net/grub-customizer/+question/279393
>
> Status: Expired => Open
>
> Daniel Richter changed the question status:
> there are no screenshots…
>
> The reason to your problem may be that Linux Mint places an image to
> /boot/grub and prefers it over the configured image. So it has to be
> removed.
>

Launchpad Janitor (janitor) said : #14

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

I assume this question is solved