3 OS on my HDD , options from GC install in the 1st OS keep the priority at boot even if i run GC from the 3rd OS with other options

Asked by malain on 2015-10-07

1st : thanks for Grub customizer
2nd: Sorry , I'm french and not speaking (writing) fuently
3rd: My problem :

I have an asus ux32 , multiboot with windows 7 and Cubuntu ( just for try it ).I use GC from Cubuntu , working well.

 After some months I install a 3rd system , Mint Rafaella , working great , So I choose this OS for everything, job and personnal . So I naturally install grub customizer in Mint , as I did from cubuntu . But ..

The way to boot stay the options of grub customizer in cubuntu . All the changes I made from GC in mint have no effect ( efficience ? ) . As Mint is my principal OS , as I may supprime cubuntu I would like to be able to customize grub from the GC of Mint ..

( I try using boot repair from mint , then GC ... but it is always the configuration of GC in cubuntu which stay the number one , the one who work and give the aspect of the boot screen ).

Thanks so much ... what to do ?

Question information

Language:
English Edit question
Status:
Answered
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Last query:
2015-10-07
Last reply:
2015-10-08

You say changes have no effect -> this mostly means that you have multiple installations of grub (one for each linux based operating system). You have to make sure that the installation you're currently configuring is shown on startup.

You do this by installing grub to MBR. This command can be found at the file menu of grub customizer. /dev/sda is ok in most cases.

Installing to MBR has to be done once only. It is not required to run it again after doing changes in the future.

btw. to 2nd: I'm not a native english speaker too. Hope we understand anyway ;-)

malain (nicklapub) said : #2

Hello ...sorry for the delay berfore responding ...

I tried to install grub on mbr from mint , it make no difference ( may be I m using EFI , and /boot partition . Then I delete the partition with cubuntu ( the 1st i used with GC ) and try to keep Mint , but the boot screen manage from cubuntu was always there , even if i used boot repair then GC from the last install ( mint ) ...

I also got some very strange entry in GC , by example Mint mount on two partition and a lot ( 60 or more of entry with old versions ) . Finally I delete all the install of linux with gparted ( cubuntu , rafaella and a partition use as clone backup of rafaella ) and reinstall Mint rafaella , and now it work

Thank for your help , if you would like to understand what happend, I did a lot of screen shot that I can transmit to you .

Have a nice day ...

Can you help with this problem?

Provide an answer of your own, or ask malain for more information if necessary.

To post a message you must log in.