Kali 1.06 64 bit install problems

Asked by Kyle Fields on 2014-03-28

Hi,

I've successfully installed in Kali 32 bit several times but in 64 bit I get dependency issues. libarchive1 and libss10.9.8 both say they are not installable. Have tried both apt-get install and aptitude install. Appreciate any tips, been fighting this for hours.

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Richter
Solved:
2014-04-01
Last query:
2014-04-01
Last reply:
2014-03-30
Kyle Fields (anon-wv) said : #1

Exact message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 grub-customizer : Depends: libarchive1 (>= 2.0.25) but it is not installable
                   Depends: libssl0.9.8 (>= 0.9.8k-1) but it is not installable
                   Recommends: hwinfo but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Kyle Fields (anon-wv) said : #2

Exact message aptitude:

The following NEW packages will be installed:
  grub-customizer{b}
The following packages are RECOMMENDED but will NOT be installed:
  hwinfo
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 855 kB of archives. After unpacking 2,720 kB will be used.
The following packages have unmet dependencies:
 grub-customizer : Depends: libarchive1 (>= 2.0.25) which is a virtual package.
                   Depends: libssl0.9.8 (>= 0.9.8k-1) which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1) grub-customizer [Not Installed]

Accept this solution? [Y/n/q/?]

Not accepting yields, "no more solutions"

I don't know why it's working on i386 while not on amd64, but that's the problem of compiled packages. They are less compatible. There are too much differences between ubuntu package versions and kali package versions.

So you have to compile from source:
https://answers.launchpad.net/grub-customizer/+faq/1397

Kyle Fields (anon-wv) said : #4

That has its own set of issues....

# cmake . && make
-- checking for module 'gtkmm-3.0'
-- package 'gtkmm-3.0' not found
-- Configuring done
-- Generating done
-- Build files have been written to: /home/****/downloads/grub-customizer-4.0.3
[ 1%] Building CXX object CMakeFiles/grub-customizer.dir/src/Model/DeviceMap.cpp.o
In file included from /home/****/downloads/grub-customizer-4.0.3/src/Model/DeviceMap.h:23:0,
                 from /home/****/downloads/grub-customizer-4.0.3/src/Model/DeviceMap.cpp:19:
/home/****/downloads/grub-customizer-4.0.3/src/Model/../lib/regex.h:24:18: fatal error: glib.h: No such file or directory
compilation terminated.
make[2]: *** [CMakeFiles/grub-customizer.dir/src/Model/DeviceMap.cpp.o] Error 1
make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
make: *** [all] Error 2

I do have glib.h, its at /usr/include/glib-2.0/glib.h . I don't know how to tell it to look there though....

libgtkmm-3.0-dev is missing.

Kyle Fields (anon-wv) said : #6

Thank you! All set.

Kyle Fields (anon-wv) said : #7

Thanks Daniel Richter, that solved my question.