Booting from a usb port

Asked by Noah Mushkin on 2014-03-02

Hi, I tried to use a chainloader to set up booting from my usb drive as you said in another answer, but in gparted, the usb is shown as being on /dev/sdb1 but in Grub Customizer I see no option to choose a chainloader for /dev/sdb1 and instead only see /dev/sda1, /dev/sda2 and /dev/sda3. I am wondering how to make the chainloader work for /dev/sdb1 and also I am on a macbook air so no BIOS from windows is active or anything like that. This is my last resort to fix the computer. Thanks and could you please walk me through detailed how to go about this?

Question information

English Edit question
Grub Customizer Edit question
No assignee Edit question
Last query:
Last reply:

The partition selection of grub customizer uses "blkid" to find the available partitions.

What's the output of "sudo blkid" (after connecting the stick)?

Noah Mushkin (noah-t) said : #2

Whe I run sudo blkid through the terminal, I get the following whe the usb drive is inserted, the usb drive is the one named WININSTALL

 sudo blkid
/dev/sda1: UUID="D86E-46EE" TYPE="vfat"
/dev/sda2: UUID="cc25dbf1-3aa9-417c-8c99-0cffbe779fd6" TYPE="ext4"
/dev/sda3: UUID="ee1801b7-4f0a-400c-9a33-cb402b959a72" TYPE="swap"
/dev/sdb1: LABEL="WININSTALL" UUID="3AD6-1B19" TYPE="vfat"

Noah Mushkin (noah-t) said : #3

Hi, after running ls in the GRUB2 command line, I booted back into Ubuntu to see if anything had changed and now Grub Customizer is seeing the USB drive correctly, also, I changed the drive itself to contain only an .ISO image instead of the files which the mac bootcamp made, about to try booting this way.

Noah Mushkin (noah-t) said : #4

Sorry to add another comment, but at the GRUB menu, the custom usb option i created in Grub Customizer is not showing up. Also, if it helps, when I ran the commands
grub> set root='(hd1,1)'
grub> chainloader +1
I got "Invalid EFI file path" after the second.

Noah Mushkin (noah-t) said : #5

When I rebooted again GRUB showed the option I added via GRUB Customizer but when I selected it I got
error: no argument specified.
error: unknown command 'drivemap'.
error: invalid EFI file path.

Press any key to continue...

Also, the USB drive solely contains a windows .ISO image in case it helps, could it be the way that the drive is formatted? or the .ISO itself?


The commands seem to be completely different for efi systems.

Please try to set the boot code manually (Grub Customizer has a source tab at the entry editor which let's you paste your own code). Here's a description about how the commands have to be formatted:

I think in your case it has to be the following content:

  insmod part_gpt
  insmod fat
  insmod search_fs_uuid
  insmod chain
  search --fs-uuid --set=root 3AD6-1B19
  chainloader /EFI/Microsoft/Boot/bootmgfw.efi

Can you help with this problem?

Provide an answer of your own, or ask Noah Mushkin for more information if necessary.

To post a message you must log in.