Cannot launch grub-customizer

Asked by HabsFanInOz on 2013-05-26

I recently upgraded to Ubuntu 12.04 from 10.04 using the upgrade functionality in update-manager. I have a dual boot set-up with Windows XP on /dev/sda and Ubuntu on /dev/sdb. After the upgrade, grub wouldn't work (it went straight to the grub rescue prompt), but I solved that by going to the BIOS boot menu and booting Ubuntu from there. I then installed grub-customizer and used it to install grub to the MBR, and everything worked fine when I rebooted - I got a splash screen with menu entries for both OSes.

However, now when I try to launch grub-customizer (using sudo grub-customizer), I get the following error message popping up in a box:

>please Inform the author about this problem. The following information could be helpful:
>
>exception '15AssertException'
> with message 'found unexpected file on path: /etc/grub.d/20_memtest86+'
> in /build/buildd/grub-customizer-3.0.4/src/Model/ListCfg.cpp:952

Also, the output at the terminal is as follows:
Ubuntu1:~> sudo grub-customizer
 *** initializing (w/o specified bootloader type)…
   * reading partition info…
   * Loading Framebuffer resolutions (background process)
   * Finding out if this is a live CD
 *** initializing (w/ specified bootloader type)…
   * Checking if the config directory is clean
 *** cleaning up config dir
 *** cleaning up cfg dir!
   * re-activating 30_os-prober
   * re-activating 41_custom
   * re-activating 40_custom
   * re-activating 20_linux_xen
   * re-activating 10_linux
   * re-activating 20_memtest86+
   * re-activating 30_uefi-firmware
   * renaming PS_memtest86+

Any suggestions?

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Richter
Solved:
2013-05-27
Last query:
2013-05-27
Last reply:
2013-05-26

The update added some duplicates which caused problems (however the fallback behaviour of grub customizer fails here… that's odd. 'll fix it in future releases.).

Please remove these files:
/etc/grub.d/PS_linux
/etc/grub.d/PS_memtest86+

Then you should be able to run grub customizer successfully.

HabsFanInOz (aphatak) said : #2

Thanks a lot - after removing those files, grub-customizer launches successfully.

silentpanther (geopard) said : #3

I had a simmilar problem, I think it was:

>please Inform the author about this problem. The following information could be helpful:
>
>exception '15AssertException'
> with message 'found unexpected file on path: /etc/grub.d/10_linux'
> in /build/buildd/grub-customizer-3.0.4/src/Model/ListCfg.cpp:952

I am not sure about the version any more but it was this file.
I renamed it into 10_linux_dead and GRUB-Customizer startet, it took a long time to load but it worked.

This is what I made my GRUB look like:
(It's not possible to screenshot the GRUB :p so it's 2 pictures.)

http://imgur.com/NZZLzSg,Ds69ORy#0
http://imgur.com/NZZLzSg,Ds69ORy#1

Thank you Daniel Richter for that great tool :-)