No timeout (e. g. wait for the user to make a choice) not working?

Asked by razuchan on 2013-04-12

Is there a way to remove the timeout, so that GRUB waits forever for the user to make a choice? As far as I remember, you have to set GRUB_TIMEOUT = -1 if you're editing the config manually, but I can't set it to -1 in Grub Customizer - the spinner doesn't go below 0, and if I type -1 there manually, it reverts it to 0 when the edit control loses focus. With 0 it makes GRUB to load the default OS instantly. Un-checking "GRUB_TIMEOUT" in advanced options also seems to have no such effect.
(Ubuntu 12.10 32 bit with the default shell (Unity or whatever), dual-boot with Windows 7 64 bit, if that matters)

Question information

Language:
English Edit question
Status:
Answered
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Last query:
2013-04-12
Last reply:
2013-04-12

Okay, I'll implement this.

You should be able to do this be modifying the value of "GRUB_TIMEOUT" inside of the advanced settings dialog. After doing this, the timeout inside of the spin button will be 0, however it should work anyway as long as you don't change the spin button.

Can you help with this problem?

Provide an answer of your own, or ask razuchan for more information if necessary.

To post a message you must log in.