GC3 difficulties installed in Lubuntu12.10 on multiboot machine

Asked by John McCarthy on 2013-01-14

 T43p Thinkpad w/250 Hard Drive consists of

sda1/2 Win7
sda5 Ubuntu 12.04
sda7 Mint 13xfce
sda8 Lubuntu 12.04
sda9 Peppermint3
sda10 Ubuntu 12.10
sda11 Lubuntu 12.10
Trying to "simplify" boot menu but keep getting an extra menu entry for 'Ubuntu 12.04.1 LTS (12.04)' see note *_*
NOT sure how to use "Look for other OS's (currently enabled) to limit boot menu to my customized entries.

At boot I currently show:

Lubuntu 12.10 9 (1st boot sda11)
Memory Test (memtest86+)
Memory Test (memtest86+,serial console)
Ubuntu 12.04.1 LTS (12.04) *note_this is the redundant entry*
Lubuntu 12.04.1 LTS (sda8)
Ubuntu 12.04.1 LTS (sda5)
Windows 7 (loader) (on /dev/sda1)
Ubuntu 12.10 (sda10)
Windows 7 (loader) (on /dev/sda2)
Linux Mint 13 Maya (XFCE sda7)
Peppermint Three (sda9)

Would like to list all but redundant 'Ubuntu 12.04.1 LTS (12.04)'

Thank you sir for a wonderful tool sir!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Richter
Solved:
2013-01-20
Last query:
2013-01-20
Last reply:
2013-01-20

Hi. I need some files to debug this problem. I'll send an email to you where you can reply with attachments.

I found the reason: because there are multiple "Ubuntu 12.04.1 LTS (12.04)" instances, Grub Customizer isn't referencing them correctly.

I'll change the behavior so that the entries will be references by content hash instead of name if the name isn't unique.

John McCarthy (yellowpiker) said : #3

Looking forward to it THANK YOU!!!

You can update to 3.0.4 now.

John McCarthy (yellowpiker) said : #5

Thanks Daniel Richter, that solved my question.

John McCarthy (yellowpiker) said : #6

Sincere THANKS to Mr. Richter!!!