Fedora 17 missing dependencies

Asked by KitchM on 2013-01-08

I have a new install of Fedora 17 and cannot find all the dependencies needed. Listed in the README file are the following:
libgtkmm-2.4-dev
cmake
libssl-dev

Of those, only cmake exists in the repository.

Is this old software that doesn't work with modern systems? If the dependencies are non-standard, why aren't they includedin the download file? Where can one find the missing files and will they be compatible?

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
KitchM
Solved:
2013-01-09
Last query:
2013-01-09
Last reply:
2013-01-09

Oh… I should update the README file. The package names are distribution specific (they are valid for debian-like systems).

Please follow the instruction on this page: https://answers.launchpad.net/grub-customizer/+faq/1397

KitchM (tech-frontrowcomputer) said : #2

Okay, that seems to help.

I found the correct dependency files and installed them first. Then I ran the "cmake . && make" command without any errors. The * hwinfo command returned "bash: changelog: command not found".

"sudo make install" ran okay, and a menu item entitled "Grub Customizer" appeared under "Administration".

Running that app showed a screen that displays environmental setup. It fails to work on sda1, partition 1, the /boot partition because it can't find fstab. It accepted sda3, the root partition.

Then it showed a number of icons with no mouse-over explanations. Some seemed like warnings. Don't know what to do with that.

When I select Apply, I get a message that says:
grub-mkconfig couldn't be executed successfully. error message:
 sh: grub-mkconfig: command not found

When I try grub-mkconfig in a terminal, the response is:
bash: grub-mkconfig: command not found

What now?

> The * hwinfo command returned "bash: changelog: command not found"

This is no command. You should only check whether hwinfo is installed.

> Running that app showed a screen that displays environmental setup
> It accepted sda3, the root partition.

Yes, the commands to generate the list are on the root partition. If required you can mount your boot partition too. However if you're just manipulating the bootloader of your currently running system you just need to choose the topmost option "(current)".

> Then it showed a number of icons with no mouse-over explanations. Some seemed like warnings. Don't know what to do with that.

This lets you change some commands. Error means that the command doesn't exist. Fedora has slightly different commands. You'll find the correct fedora configuration at the end of the FAQ page I sent you before (https://answers.launchpad.net/grub-customizer/+faq/1397). You can either put each setting and choosing the option "save this configuration" or creating the file manually (this may be faster as you can copy&paste the whole file from the FAQ).

KitchM (tech-frontrowcomputer) said : #4

If hwinfo is not installed, should it be?

I finally figued out that the warning triangle and the circle red bar are indicating that the item listed is wrong or missing. It turns out that the program defaults are set to old settings, and most of them can be fixed by changing grub to grub2.

However, the line that is entitled "MKDEVICEMAP_CMD:", I couldn't fix.

How should I fix that?

grub2-mkdevicemap doesn't exist?

KitchM (tech-frontrowcomputer) said : #6

No, it doesn't.

I have the before and after shot of the config screen, but I don't know how to attached it.

Alternatively, if you have a static device map file (e.g. /boot/grub2/device.map), you don't need this command. You should be able to continue.

about the screenshot:
Yes, it's not possible to attach images here :-(
But I know what you are talking about.

KitchM (tech-frontrowcomputer) said : #8

Yes, there is a /boot/grub2/device.map.

Thanks for your great and timely help.

Now I am going to try to use the program and see what happens.

By the way, would you like me to document the process we've gone over so far so as to create the necessary steps for this distro? I'd be glad to do so and send it to you wherever you like.

That's great.

I've seen there are some documents I have to update (README and also the FAQ are not up to date).

I want to have only one FAQ page for both/all distros. Otherwise it would be too hard too keep it up to date. If you want to write an article on another place (forum etc.) - feel free to do it.

The best thing would be a fedora rpm package linking to the required packages and containing the command list (/etc/grub-customizer/grub.cfg). Are you familiar in creating rpm packages?

Sorry, I'm a good documenter, but a poor scripter.

I could still give you the steps I went thru to make it work, if you wanted to add that to the README.

Is there any other documentation for how to use the program? The help menu has nothing and there is no mouse-over or context menu assistance or explanations.

Thanks.

There's http://ubuntuforums.org/showthread.php?t=1664134 - but it's a little bit older. The current version has another user interface.

When you start the app, you see the list of menuentries and also some special entries. the normal menuentries are what you see when you're booting. They have bold text. The special entries: "incoming entries" is the place where grub2 puts new entries (new operating systems, new kernels, …) and "script-code" represents stuff like function definitions etc (it's more an internal thing which shouldn't be removed).

You can do all changes in 2 ways: by selecting entries and clicking any button of the toolbar or by right clicking an entry and selecting the action from the context menu. Delete isn't a permanent action. It just hides the entry. To restore it you can use the internal "trash". Removing the "incoming entries" placeholder means that new operating system won't be visible automatically. They'll be in trash by default.

I just changed the colors and the font and size. When I rebooted, I could read the menu. On my big screen it was too tiny to read. So that helped a great deal.

But it said I needed to change the image if I wanted to change the colors, which didn't make any sense at all. It also had a place for resolution, but it did not offer any choices.

So anyway, I guess it is working, and I thank you very much for the help. I will visit that link you gave and read what they have there.

Thanks again.

Hmm this may be different on fedora. Ubuntu/Debian only uses the colors if you also choose a background image. However this logic is inside the /etc/grub.d/05_debian_theme ;-)

To get the resolution dropbox you have to install hwinfo. This is a command which lists the available resolutions for grub2. Alternatively you can manually write the resolution you want to use into the field. You have to use a format like this: 1920x1080x24

Hi askway,

there are some "soft" (means that it works without, but improves some details) dependencies:

 * hwinfo (used to detect available resolutions)
 * policykit (used to get root permissions when launching without root permissions - menu, command line, …)

Do you know whether there's a build system which can be added as additional software source from the user (like PPAs)?