No background image or Menu Colours

Asked by Nick Fane on 2012-09-10

I have added a background image file (.jpg) and chosen Menu Colours. Both show in the preview box, but neither appear in GRUB at boot.
Other changes have worked.
I am using Peppermint3 OS.
Any suggestions?

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Richter
Solved:
2012-09-11
Last query:
2012-09-11
Last reply:
2012-09-11

Is it written to your /boot/grub/grub.cfg (please search for the file name of your image)?
Is there either a /etc/grub.d/05_debian_theme or /etc/grub.d/06_grub-customizer_menu_color_helper?

Nick Fane (nick-xrvasaslqc) said : #2

Thanks for very rapid response Dan. I should start by saying I'm very new to Linux, so please excuse any silly mistakes!
I have looked in the grub.cfg file: I can't find my .jpg file; There is a section grub.d/05_debian_theme

Thank you. I have some further questions:

 * do you find the file image path inside of the /etc/default/grub file (should starting with "export GRUB_MENU_PICTURE=")
 * Does the file /usr/share/desktop-base/grub_background.sh exist?

 -> if both anwers are true, please post the contents of your /etc/grub.d/05_debian_theme

Nick Fane (nick-xrvasaslqc) said : #4

The file /usr/share/desktop-base/grub_background.sh exist does exist.
Am I meant to be looking for "export GRUB_MENU_PICTURE= .... " in the grub.cfg file? - if so, I cannot find it.

Please open Grub Customizer and change the background image. Then click the advanced settings button (bottom right). Is there something like GRUB_MENU_PICTURE?

Nick Fane (nick-xrvasaslqc) said : #6

YES - and it clearly points to the picture I tried to load.
I haven't 'changed' it again, that is the result from my previous attempt.

Is there a /etc/grub-customizer/grub.cfg?

Nick Fane (nick-xrvasaslqc) said : #8

Am I looking for a grub-customizer folder?
I can't find one - BUT I'm not quite sure where I should be looking, can you be a bit more specific?

Nick Fane (nick-xrvasaslqc) said : #9

Just realised that "/etc/" is actually a folder - sorry!
But, it does NOT contain another folder called grub-customizer

it's ok. Then this file doesn't exist. I'm just wondering where it loads/saves the grub configurations on your system. /etc/grub-customizer/grub.cfg is a way to modify the pathes. Otherwise the built-in pathes are used. It's ok.

Please post your /etc/default/grub here. I want to make sure.

Nick Fane (nick-xrvasaslqc) said : #12

I hope I should not have looked in that file before!
I am 'talking' to you from my Windows Desktop - the Peppermint3OS is on a separate laptop. I have copied the contents of the file across:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

export GRUB_COLOR_NORMAL="light-gray/black"
export GRUB_COLOR_HIGHLIGHT="yellow/light-magenta"
export GRUB_MENU_PICTURE="/home/fane/Pictures/Sky -A1A_9828.jpg"
GRUB_FONT="/boot/grub/unicode.pf2"

ok, that means the image exists inside of the settings file.

When you're running `sudo update-grub` - if there something like "Found background image:"?

Nick Fane (nick-xrvasaslqc) said : #14

Oh dear - this sounds like I may have misunderstood something.
I have just 'saved' in grub-customizer and the 'Install to MBR' - I did not find a clear 'idiots guide' for the Linux-novice on that point.
Should i have run 'sudo update-grub` as well ?

No. Clicking save runs an update-grub itself. However running it directly shows some more information.

Nick Fane (nick-xrvasaslqc) said : #16

Dan, Thanks for trying so hard and so quickly. I'm guessing that you may be 'signing off' for today - and I certainly need to soon. I will look forward to any further suggestions in due course. Thanks again.

just to make sure - my suggestion is still: running `sudo update-grub` and looking for something like "Found background image:"

Nick Fane (nick-xrvasaslqc) said : #18

Dan, thanks, I have run 'sudo update-grub' - but it hasn't changed anything.
Here is the text output shown on the terminal:

fane@Fane-LT ~ $ sudo update-grub
[sudo] password for fane:
Generating grub.cfg ...
using custom appearance settings
Found background image: /home/fane/Pictures/Sky-A1A_9828.jpg
Found linux image: /boot/vmlinuz-3.2.0-23-generic
Found initrd image: /boot/initrd.img-3.2.0-23-generic
Found Windows Vista (loader) on /dev/sda2
Found linux image: /boot/vmlinuz-3.2.0-23-generic
Found initrd image: /boot/initrd.img-3.2.0-23-generic
Found memtest86+ image: /boot/memtest86+.bin
Found linux image: /boot/vmlinuz-3.2.0-23-generic
Found initrd image: /boot/initrd.img-3.2.0-23-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows Vista (loader) on /dev/sda2
done
fane@Fane-LT ~ $

It appears to be finding the image - but it still does not appear in GRUB, nor do the background colours.
The listing order, text font and size were updated.

Does that move us on?

Then it's because of the image. Grub2 ignores the image in some cases (but I don't know what's the reason). Sometimes it helps to convert the image to PNG.

Nick Fane (nick-xrvasaslqc) said : #20

OK. I'll try some alternative images later and let you know the outcome.

Nick Fane (nick-xrvasaslqc) said : #21

Hi Dan

It looks like the problem is related to the picture file.
I immediately suceeded with a different picture file (1024x768) in PNG format.

However, I subsequently tried a few others, one 640x480, one 1026x768 - and even another plain blue file at 1024x768 - I can't get ANY of those to work!

But, when I return to the original 1024x788 file it works again.
There is something 'lucky' about this file, but I can't fathom what!

Ok, then the problem is not in Grub Customizer but in Grub2. Unfortunately i cannot say more about this problem. Just noticed it, but didn't find out what's the reason for Grub2 to ignore the image (while the config is written correctly).

Nick Fane (nick-xrvasaslqc) said : #23

OK - I'm sure you agree that it would be 'nice' to find some clue as to what is required to make a particular image work.
I fully understand now that it isn't a Customizer problem.
Any ideas where to look?

Nothing special. I would try to find problems like this in forums/howTos/… and if nothing found asking the developers of Grub2 (creating bug or something similar).

Nick Fane (nick-xrvasaslqc) said : #25

OK, and thanks fo rall your efforts - much appreciated.

Nick Fane (nick-xrvasaslqc) said : #26

We'll close this then.

Nick Fane (nick-xrvasaslqc) said : #27

Thanks Daniel Richter, that solved my question.

Nick Fane (nick-xrvasaslqc) said : #28

Further investigation with image files suggests that the problem may well be related to file size.
It turns out that some of the files I used earlier were not the aspect ratio or size I was led to believe - but they were RGB (non-indexed colours), which seems to be a requirement of GRUB2.
The picture file that did work was 1024x768 px in PNG format.
I have now created a plain colour file 640x480 px in PNG format - and that worked too.
Note that 1024x768 is a multiple (x1.6) of 640x480 - and I have seen suggestions that GRUB2 may require the 640x480 aspect ratio.
I hope that may help someone else with this problem.