"sed: cant read" error

Asked by foolishgrunt on 2012-01-13

I just installed Grub Customizer 2.5.1 today, but I haven't been able to get it to work properly yet. I compiled it from source as per the directions here:
https://answers.launchpad.net/grub-customizer/+faq/1397

When I start the program, after I enter my root password, the main window appears and begins populating the OS list. But before it finishes populating the list, I get the following popup:

burg-mkconfig couldn't be executed successfully.
error message:
 Generating burg.cfg ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
  No volume groups found
Found Windows 7 (loader) on /dev/sda1
Found Arch on /dev/sda2
Setup resume hook
Adding swap partition /dev/sda4
sed: can't read .new: No such file or directory

When I close the popup window, the program terminates. As you can see, I'm using Burg, but I don't believe that's causing the problem. The sed error message at the bottom seems to be the issue. It also appears at the bottom of the terminal output when I run "sudo burg-mkconfig."

On a hunch, I created a /etc/grub-customizer/burg.cfg file as suggested in the installation FAQ, ensuring that all the directories and commands are correct. That didn't change anything.

Anbody have an idea on how to fix the error? I'm running Chakra Linux Edn 2011.12 (the latest version).

Question information

Language:
English Edit question
Status:
Answered
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Last query:
2012-01-13
Last reply:
2013-01-12

If you didn't do any modifications using grub customizer, it's because of a burg specific problem, I think…

You can try to disable some scripts at /etc/burg.d (by removing the executable permission - chmod -x …) and trying again afterwards. If this doesn't help or the failing script is essential, make sure the /etc/burg.d directory is clean (no directories, no *-proxy files) and contact the developer of burg.

It isn't sensitive to try grub customizer while update-burg (or burg-mkconfig) doesn't work.

Check if /boot/burg/locale is present. If not, try copying /boot/grub/locale to /boot/grub/locale. See if it helps. Worked for a similar problem for me.

Can you help with this problem?

Provide an answer of your own, or ask foolishgrunt for more information if necessary.

To post a message you must log in.