Grub Customizer 2.5.1 in Kubuntu 11.10 & 12.04 won't open from Menu

Asked by Flames_in_Paradise on 2012-01-09

hi!

Using Grub Customer since a while + like it a lot!

Currently it cannot be called up from the menu in Kubuntu 11.10 & Kubuntu 12.04. It only turns up if I use the keys ALT+F2 and enter "kdesudo grub-customer"

Why is this function to call the programm from the menu-entry broken in Kubuntu?

Should we open a bugreport to receive the exspected behaviour ?

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
Flames_in_Paradise
Solved:
2012-01-10
Last query:
2012-01-10
Last reply:
2012-01-09

What happens when you're running `grub-customizer` (no sudo, no root shell!) from the command line?

Some backgrounds: since v2.5 I switched from the sudo related commands (su-to-root which is based on gksu, kdesudo etc.) to policykit (the pkexec command) as this doesn't require the "menu" package. pkexec is installed by default and other distributions mostly doesn't come with a package containing the su-to-root command. When running without root permissions, it runs itself using pkexec. But when it's already running as root (kdesudo, …), pkexec isn't used.

hi!

Thanks for pretty fast reply!

I actually get an error window in K11.04: grub-mkconfig konnte nicht erfolgreich ausgeführt werden. Fehlermeldung:
 grub-mkconfig: You must run this as root

Lines in the Terminal:

@Home-Desktop:~$ grub-customizer
 *** initializing (w/o specified bootloader type)…
   * reading partition info…
   * Loading Framebuffer resolutions (background process)
   * Finding out if this is a live CD
     [running on an installed system]
     [checking the burg-mkconfig command… ]
     [not found]
     [checking the grub-mkconfig command… ]
     [found at: /usr/sbin/grub-mkconfig]
     [checking the update-grub command… ]
     [found at: /usr/sbin/update-grub]
     [checking the grub-install command… ]
     [found at: /usr/sbin/grub-install]
 *** initializing (w/ specified bootloader type)…
     [checking the grub-mkconfig command… ]
     [found at: /usr/sbin/grub-mkconfig]
     [checking the update-grub command… ]
     [found at: /usr/sbin/update-grub]
     [checking the grub-install command… ]
     [found at: /usr/sbin/grub-install]
process 28044: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
   * Checking if the config directory is clean
 *** loading configuration
 *** loading - preserveConfig: no
   * unsetting saved config
 *** loading settings
 *** loading grub list
   * loading scripts…
   * loading proxies…
   * creating proxifiedScript links & chmodding other files…
   * running grub-mkconfig
     [running GrubCustomizer::syncListView_load]
     [GrubCustomizer::syncListView_load completed]
     [running GrubCustomizer::syncListView_load]
     [GrubCustomizer::syncListView_load completed]
     [running GrubCustomizer::syncListView_load]
     [GrubCustomizer::syncListView_load completed]
     error while loading the grub list

Well I read the manpage on root-to-su and am astonished myself it doesn't work out as it's meant.

No, please use (K)Ubuntu 11.10 or 12.04. The Grub Customizer versions for older Ubuntus are still based on su-to-root.

O.K. I'll be back in a few minutes, just got to start the VM with K12.04

No, please forget sudo ;-)

You wrote your exists on (K)Ubuntu 11.10/12.04… so sudo is not used by the menuentry!

Thats from K12.04

<username>@Home-PC:~$ grub-customizer
No protocol specified

Gtk-WARNING **: cannot open display: :0
<username>@Home-PC:~$

excuses this was GC 2.5.0 in K12.04

running a few updates and be back in a moment- Had to restart :-( the VM

Verified. It's the same result as posted in comment #7 with GC 2.5.1 in K12.04, wt all updates as per today

The problem seems to be the same like here: https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/829099

Anyway, synaptic isn't the real problem, the problem relies somehow on a bug in kdm…

To fix it on your system, make sure the "menu" package is installed. Then change the Exec line in /usr/share/applications/grub-customizer.desktop to "Exec=su-to-root -X -c grub-customizer"

Same console-output for K11.10 (updated as per today) with GC 2.5.1 as posted in comment #7

Well changed it like requested into:

[Desktop Entry]
Name=Grub Customizer
Comment=Customize the bootloader (GRUB2 or BURG)
Exec=su-to-root -X -c grub-customizer
Terminal=false
X-MultipleArgs=false
Type=Application
StartupNotify=false
Categories=System;Settings;
Icon=grub-customizer
X-Ubuntu-Gettext-Domain=grub-customizer

This doesn't change the undelightful misbehaviour. ;-):

> This doesn't change the undelightful misbehaviour. ;-):

When using the menu or when running it from the terminal?

both is unchanged in 11.10 & yes there seems to a parallel to the behaviour of Synaptic in KDE.

For the time beeing, until a proper solution is worked out, I still can start GC with ALT+F2 named KRunner in KDE and call for "kdesudo grub-customizer" then the programm comes up -> password -> looks fine

But the "menu" package is installed?

Yes, had checked on this beforehand, as you asked for.

O.K. works now in KDE 11.10 . Thanks for your Patience

Explanation: KDE seems to store .desktop files in another place as in /usr/share/applications/... (might be worth looking at)

Had placed the Exec= as my fault in the commandline via the menu-editor (rightclick on KDE-Startbutton) - Corrected this and now I'm happy again.

I'll check on this now in KDE 12.04

Trying it now with a different approach in K12.04, gathering situation as is beforehand:

menu Version installed: menu_2.1.46ubuntu1_i386 is installed
GC Version installed: 2.5.1

edited file /usr/share/applications/grub-customizer.desktop:

[Desktop Entry]
Name=Grub Customizer
Comment=Customize the bootloader (GRUB2 or BURG)
Exec=grub-customizer
Terminal=false
X-MultipleArgs=false
Type=Application
StartupNotify=false
Categories=System;Settings;
Icon=grub-customizer
X-Ubuntu-Gettext-Domain=grub-customizer

Changed the line:

Exec=su-to-root -X -c grub-customizer

Waited 3 seconds, called Grub Customizer from the Menu. Fine & Thanks this solved my question

Does this mean I have to run the same procedure if I update GC now for Natty 11.04? ;-) or can I wait 'til you push an update. I pretty much like idea better to settle things via answers@launchpad than via bugs@launchpad

The idea came in forum-thread... Thanks again for this pretty piece of software. Daniel. Hopefully the Fedora guys wil evaluate it much higher than the ubuntu-guys, which are more familiar with GRUB-2 since they know it a little longer.

The problem didn't occur with Natty 11.04. (32-bit) Keeping in mind beeing on the "safe side" I opened grub-customizer_2.5.1-0ubuntu1~ppa1n_i386.deb using ARK and took a brief look into the regarding .desktop file