No Bootloader Found when Using grub2-efi-x86_64

Asked by Jeremy Lilly on 2011-11-30

I have installed Arch Linux using grub2-efi-x86_64 as my bootloader. However, when running Grub Customizer, I am told that no Bootloader is found. I went through the wizard and mounted my root partition, but no joy.

Is Grub Customizer compatible with an efi system?

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Richter
Solved:
2011-12-30
Last query:
2011-12-30
Last reply:
2011-12-30

To pass the system requirements, you need to have theese commands:

grub-mkconfig
update-grub
grub-install
which (used to check wether the commands are available)

… and this directory:
/etc/grub.d

Please check them manually.

Alan Childs (r7an) said : #2

I have the same problem on Fedora 16, grub2-1.99-12.fc16.i686.

Instead of grub-mkconfig I have grub2-mkconfig, and none of the other files. In order to get them installed on Fedora 16 I need to installed Grub1 packages or do some dodgy hacks, so I assume there is some distro issues.

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

btw. the new Release 2.5 allows to configure the commends/pathes

Take a look at: https://answers.launchpad.net/grub-customizer/+faq/1397

Jeremy Lilly (jeremylilly) said : #5

Sorry for the delay posting more info. (Been out of town, etc.)

I see that the new Release 2.5 allows you to configure the Commands/Paths, which will solve part of the problem. Specifically, for UEFI systems, the bootloader is located in a different system partition. For Arch Linux, this is /boot/efi. So, the path to the grub.cfg would be /boot/efi/efi/grub/grub.cfg. With this new option in Release 2.5, I could point to the new directory.

However, the one problem that still exists for me, is that update-grub does not exist on an Arch Linux install. Apparently, that seems to be an Ubuntu specific command? I'm not really clear on how it is different than grub-mkconfig. Is there any way around this?

Yes. You can use:

grub-mkconfig -o /boot/efi/efi/grub/grub.cfg

as UPDATE_CMD

Jeremy Lilly (jeremylilly) said : #7

I totally overlooked that in the configuration file that was added in Release 2.5.

Excellent, with those modifications, this should work great. Thank you for your responses!

Jeremy Lilly (jeremylilly) said : #8

Thanks Daniel Richter, that solved my question.