help! I seem to have turned off everything except memtest and I can't boot ubuntu or windows

Asked by mistafeesh on 2011-01-14

I thought I was turning off various extra options in grub customizer and I really should have made a rescue boot disk, but I messed around and somehow now all grub2 comes up with is memtest. I was just trying to make it a bit less complicated

I've tried various things from the grub command line and the ubuntu liveCD (10.10) but I can't get it up and running again. Can you help?

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
mistafeesh
Solved:
2011-01-14
Last query:
2011-01-14
Last reply:
mistafeesh (dan-oxdance) said : #1

I followed instructions to purge and reinstall grub2 from the liveCD here: http://ubuntuforums.org/showthread.php?t=1581099 but it still comes up with just memtest - I guess it's still finding the custom file I've made somewhere.

I also tried pressing c in grub2 and manually booting linux, but didn't get anywhere....

mistafeesh (dan-oxdance) said : #2

phew! fixed it! Sorry to bother you. I see now that i'd somehow unticked linux boot. D'oh!
 I followed these instructions to boot: http://techgage.com/news/repairing_a_broken_grub_2_boot-loader_on_ubuntu/ and went into grub customizer and reticked stuff!

Hi,
another way to restore your grub configuration would consist of installing grub customizer inside the live system (temporarily) and to run it from there. It will show up a dialog which lets you choose your root partition. After doing this you can use grub customizer in the same way as inside an installed system.

mistafeesh (dan-oxdance) said : #4

That's cool I didn't think of that... I had unticked the tick for the whole linux section without realising it covered all the subsections too... Maybe in a future release it might be a good idea to indent them a little more? Just for daft people like me! Fantastic bit of software though. I've just set ubuntu up on a friends computer and wanted to simplify his boot process because grub was looking really confusing. I've used it on my dual boot laptop too now.

Hmm I don't want to increase the width of the checkbox column too much… but instead I'll gray out all the entries owned by disabled scripts in the next release (2.1). I hope this is okay too :)

mistafeesh (dan-oxdance) said : #6

Yeah that sounds sensible.