Launchpad Ground Control

GroundControl configuration files

Asked by Martin Lukeš on 2010-02-05

I wanted to change GCs localization, but I can't figure out how.
Where are GCs configuration files located?

Question information

Language:
English Edit question
Status:
Solved
For:
Ground Control Edit question
Assignee:
No assignee Edit question
Solved by:
Martin Lukeš
Solved:
2010-02-05
Last query:
2010-02-05
Last reply:
2010-02-05
Martin Owens (doctormo) said : #1

There are no configuration files for Ground control, none that control language anyway.

The language is only configurable by changing the localisation of nautilus, or changing the localisation of the whole desktop.

But if you want to change it for development and testing you might be able to set it on the commnand line and run nautilus from there:

nautilus --quit; nautilus --no-desktop

Then I don't understand.
I have cs_CZ.UTF-8 locale set for all system, Nautilus is in Czech, but Ground Control is in English.

Martin Owens (doctormo) said : #3

It's still in English because it doesn't have a Czech translation, no one who can write Czech has helped us translate it yet.

I did!

Oh I see it now. My strings are just marked as Newly translated.

Sorry then.

Martin Owens (doctormo) said : #6

Right I just looked at it, your right you did. It's in Launchpad right now and the translation will make it's way to the release when we do an import.

If you want to force it, you can download the czech translation you've done as a po file, then put that po file in /usr/share/groundcontrol/po/

Hopefully that should work, but I'm not an expert on translations so a cache may have to be regenerated too.

Thanks for the translation by the way :-)

Hey, no problem with translating. I'm glad that you're making this project. ;-)

BTW I downloaded that cs.po file and placed it in that folder. I even tried to rename it to en.po. But it doesn't help.
Well, no harm done. I'll just wait for another release. ;)

Łukasz Jernaś (deejay1) said : #8

Erm, you have to download the "mo" file and put it in /usr/share/locale/cs_CZ/LC_MESSAGES/groundcontrol.mo

Łukasz Jernaś (deejay1) said : #9

OK, IMHO something is clearly wrong - the directory /usr/share/groundcontrol/po/ shouldn't even exist, AFAIK it's not the way gettext works...

Martin Owens (doctormo) said : #10

Łukasz Jernaś, thanks for clearing that up. Not that I have any idea how it works.

So to sum it up.
The correct way to get translation working is:
* download .po and .mo files
* sudo mv cs_LC_MESSAGES_groundcontrol.mo /usr/share/locale/cs_CZ/LC_MESSAGES/groundcontrol.mo
* sudo mv po_groundcontrol-cs.po /usr/share/groundcontrol/po/cs.po
* nautilus --quit; nautilus --no-desktop
* then you close Nautilus window, and then open it again

Locale names of course alter for your language. ;)

The only strings you won't see translated are in Ground Control Configuration window (almost all of them). Then in Nautilus some strings and Help text (blue question mark) - but this isn't translatable ... yet, I hope ;)

Łukasz Jernaś (deejay1) said : #12

The /usr/share/groundcontro/pol isn't needed and I'll remove it from the buildsystem as soon as groundcontrol manages to branch itself in my projects dir (yesterday it crashed nautilus for me with a nice 100MB stacktrace...). Oh, and BTW "nautilus --quit; nautilus --no-desktop" gives me a nice DOS on Lucid, as it falls in an endless loop restarting nautilus heh...