Issue while installing ceres on Os x 10.12

Asked by Amrish on 2017-06-07

Hi,
I am facing issue while installing ceres on Os x 10.12.
Following is the error:
creating /System/Library/Frameworks/Python.framework/Versions/2.7/plugins
error: could not create '/System/Library/Frameworks/Python.framework/Versions/2.7/plugins': Operation not permitted

Thanks,
Amrish

Question information

Language:
English Edit question
Status:
Answered
For:
Graphite Edit question
Assignee:
No assignee Edit question
Last query:
2017-06-07
Last reply:
2017-06-07
Denis Zhdanov (deniszhdanov) said : #1

please do not install Graphite with system python on OSX
Please
1) first install python through brew (https://brew.sh, then "brew install python"), it will pe installed as symlink to /usr/local/bin/python
2) then install Graphite in virtualenv - https://graphite.readthedocs.io/en/latest/install-virtualenv.html

or use vagrant and Synthesize - http://graphiteapp.org/quick-start-guides/synthesize.html

Can you help with this problem?

Provide an answer of your own, or ask Amrish for more information if necessary.

To post a message you must log in.