graphite-web: Images or graphite tree not showing

Asked by Tobias on 2017-04-13

I am trying to install graphite-web 1.0.0 (using pip) with mod_wsgi but all I see is a black header with "Documentation Dashboard Events Login" and a white body. No errors in apache error log or in the exceptions.log file. I have successfully done:

PYTHONPATH=/opt/graphite/webapp django-admin.py migrate -noinput --settings=graphite.settings --run-syncdb

Here is the output of pip freeze

backports.ssl-match-hostname==3.4.0.2
cairocffi==0.8.0
carbonate==1.0.0
cffi==1.10.0
configobj==4.7.2
decorator==3.4.0
Django==1.9
django-tagging==0.4.3
iniparse==0.4
IPy==0.75
perf==0.1
policycoreutils-default-encoding==0.1
pycparser==2.17
pycurl==7.19.0
pygobject==3.14.0
pygpgme==0.3
pyliblzma==0.5.3
pyparsing==2.2.0
pytz==2017.2
pyudev==0.15
pyxattr==0.5.1
scandir==1.5
seobject==0.1
sepolicy==1.1
Twisted==16.4.0
txAMQP==0.7.0
urlgrabber==3.10
urllib3==1.20
whisper==1.0.0
yum-metadata-parser==1.1.4
zope.interface==4.3.3

Not sure why carbon and graphite-web are not listed in there but I have installed them.

Here is the output from check_dependencies.py:

# python check_dependencies.py
[OPTIONAL] Unable to import the 'memcache' module, do you have python-memcached installed for python 2.7.5? This feature is not required but greatly improves performance.
[OPTIONAL] Unable to import the 'ldap' module, do you have python-ldap installed for python 2.7.5? Without python-ldap, you will not be able to use LDAP authentication in the graphite webapp.
[OPTIONAL] Unable to import the 'python-rrdtool' module, this is required for reading RRD.
[OPTIONAL] Unable to import the 'whitenoise' module. This is useful for serving static files.
[OPTIONAL] Unable to import the 'pyhash' module. This is useful for fnv1_ch hashing support.
5 optional dependencies not met. Please consider the optional items before proceeding.
All necessary dependencies are met.

I am trying to install on CentOS Linux release 7.2.1511 (Core)

apache user can read /opt/graphite and below.

Apache version is: Apache/2.4.6 (CentOS)

selinux is in permissive mode:

# getenforce
Permissive

Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Graphite Edit question
Assignee:
No assignee Edit question
Solved by:
Tobias
Solved:
2017-04-13
Last query:
2017-04-13
Last reply:
Tobias (lindqt01) said : #1

Solved by running the following:

PYTHONPATH=/opt/graphite/webapp django-admin.py collectstatic --noinput --settings=graphite.settings

Tobias (lindqt01) said : #2

Solved by running the following:

PYTHONPATH=/opt/graphite/webapp django-admin.py collectstatic --noinput --settings=graphite.settings