Some graphs blank when querying beyond first retention timeframe

Asked by Jason Westervelt on 2016-11-28

I'm currently using graphite 0.9.15, and I am using the following data retention scheme:
retentions = 10s:8d,1m:31d,10m:1y,1h:5y

I have tried with and without a storage-aggregation.conf, with the same effect.

The issue is that I can set the timeframe for the past 8 days within Graphite and get my graphs, as expected. When I set the timeframe to include any date earlier than that, all of the data disappears. I'd expect that if there were an issue with the retention / rolling at the 8d mark, setting my timeframe to the past 9 days would show one blank day and 8 days with data, but instead nothing is displayed at all.

This problem seems to affect several of my metrics, while others are unaffected. Just trying to find out the best way to troubleshoot this problem as I am somewhat new to Carbon/Graphite.

Question information

Language:
English Edit question
Status:
Solved
For:
Graphite Edit question
Assignee:
No assignee Edit question
Solved by:
Denis Zhdanov
Solved:
2016-11-30
Last query:
2016-11-30
Last reply:
2016-11-29
Best Denis Zhdanov (deniszhdanov) said : #1

It's a well-known thing. Some of your merics update frequency are less than your lowest retention (10s), and aggregation removes these points during aggregation. You should decrease xFilesFactor for these metrics or increase retention.
Please see answers for e.g. this question - https://answers.launchpad.net/graphite/+question/393687

Jason Westervelt (vespira) said : #2

Thanks, I got it figured out. The xFilesFactor was set at 0.5 and since fewer than half of the intervals per minute contained data, it was getting dropped. I still do not understand why the recent data was missing, but I've since blown out the whisperDB files, set my monitoring checks to a shorter interval, and everything is working as expected. Thanks for the input.

Jason Westervelt (vespira) said : #3

Thanks Denis Zhdanov, that solved my question.