Weird rendering latest metric only 48 hours on icinga2

Asked by Claudio on 2016-09-13

Hi all ,

 I have graphite-carbon 0.9.12-3 using with icinga2 on debian jessie

Weird situation the some of the metric under icinga2 works fine only few recent metric added .

 I recently I noticed effecting only latest metric added that save only 48h , also when I set data range more than 48h then the metric disappear from the graph

the setup storage-schemas.conf is always the same : http://paste.ofcode.org/YyVX8N9pe5T4mU6ZxQsDAp

Any suggestion ?

Question information

Language:
English Edit question
Status:
Solved
For:
Graphite Edit question
Assignee:
No assignee Edit question
Solved by:
Denis Zhdanov
Solved:
2016-09-13
Last query:
2016-09-13
Last reply:
2016-09-13
Jason Dixon (jason-dixongroup) said : #1

It sounds like you're not submitting metrics frequently enough. Graphite's Whisper database contains a parameter xFilesFactor that serves as a low water mark for any rollups. If you have too few datapoints it will roll them up into nulls. I've explained it more thoroughly here: http://obfuscurity.com/2012/04/Unhelpful-Graphite-Tip-9.

Best Denis Zhdanov (deniszhdanov) said : #2

If you sending metrics every 5 minutes then you need or remove 1min archive at all, or change xFilesFactor to 0 - please see http://obfuscurity.com/2012/04/Unhelpful-Graphite-Tip-9 and/or https://github.com/graphite-project/whisper/issues/166#issuecomment-243713438

Claudio (claudio-enjoy) said : #3

Thanks Denis Zhdanov, that solved my question.

Claudio (claudio-enjoy) said : #4

Solution with

storage-shemas.conf
[icinga2_default]
pattern = ^icinga2\.
retentions = 1m:2d,5m:10d,30m:90d,360m:4y

storage-aggregation,.conf
[min]
pattern = \.min$
xFilesFactor = 0.1
aggregationMethod = min

[max]
pattern = \.max$
xFilesFactor = 0.1
aggregationMethod = max

[sum]
pattern = \.count$
xFilesFactor = 0
aggregationMethod = sum

[default_average]
pattern = .*
xFilesFactor = 0.1
aggregationMethod = average

thanks @jason-dixongroup and @deniszhdanov