Problem with aggregation in graphite.

Asked by avni goyal on 2012-08-14

I am trying graphite for the first time. I want to understand why the aggregated graph in graphite is showing 1/60th of the value through carbon and 1/10th of the value I enter through statsd. How do I solve this if it can be done? I am sending this data: echo "try:1|c\n" | nc -u localhost 8125" and then adding the functions sum and integral in the UI of graphite. Please help.

Question information

Language:
English Edit question
Status:
Solved
For:
Graphite Edit question
Assignee:
No assignee Edit question
Solved by:
avni goyal
Solved:
2012-08-21
Last query:
2012-08-21
Last reply:
2012-08-16
Michael Leinartas (mleinartas) said : #1

First of all, statsd's behavior is to give you a per-second rate for counts. statsd's default flushInterval is 10 seconds - in that case it will divide the total count received during that 10 second period by 10. In your example, a single count of 1 would be stored as 0.1.

I'm not sure what you're referring to with the 1/60th value and your mention of the sum and integral functions. Is this the same data as you're testing with statsd or data that's being sent directly to carbon?

avni goyal (becool-avni) said : #2

Hey Michael,
 What i wanted was if i enter a single count of 1, it should store as 1 itself. I tried changing the flushinterval to 1000ms in local.js (copy of exampleConfig.js), but it still did not store it as 1.
The 1/60th value came when i was sending data directly to carbon. Please let me know how can I store the same value that i enter.

avni goyal (becool-avni) said : #4

hi! This is what is happening now -
When i send a value of 100 to graphite, it adds but if i give a value of 10 immediately, it is dropping the complete value. I think its because graphite is averaging the values that i give. I dont have any average function in my storage-aggregation.conf. Please help!

avni goyal (becool-avni) said : #5

Problem solved: Just had to set the flushinterval of statsd to 60s. It works fine now.