graphite-web and carbon re-install every time I execute the install option with pip

Asked by Tom Purl on 2012-08-09

I am using Puppet to provision a small VM that hosts graphite, and I am installing the graphite components using pip.

It's my understanding that Puppet checks each pip-installed package by trying to install the application. If pip returns a message saying that it's already installed, it moves on. Otherwise, it will install the app again using pip.

Whisper tells pip that it's already installed, so Puppet doesn't try to do it more than once. However, every time I reboot my VM, Puppet reinstalls graphite-web and carbon.

I found the following potential answer to my question:

http://stackoverflow.com/questions/7971799/pip-always-reinstalls-package-when-using-specific-svn-revision

In this example, it looks like the issue is with an egg name in the pip package.

I'm not a regular pip user, so I don't know if this is a bug or not. Should the egg name be changed? If not, then should something else be changed so that the carbon and graphite web packages are more compatible with Puppet?

Thansk in advance!

Tom Purl

Question information

Language:
English Edit question
Status:
Solved
For:
Graphite Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Leinartas
Solved:
2012-08-14
Last query:
2012-08-14
Last reply:
2012-08-14
Best Michael Leinartas (mleinartas) said : #1

Looks like this was reported here as well: https://bugs.launchpad.net/graphite/+bug/1022576

Until this gets fixed, Stackoverflow has an example workaround for puppet here: http://serverfault.com/questions/358151/pip-install-carbon-looks-like-it-works-but-pip-disagrees-afterward

Tom Purl (tompurl) said : #2

Thanks a ton Michael, this works great for me.

Tom Purl (tompurl) said : #3

Thanks Michael Leinartas, that solved my question.