graphs that have maths calculations suddenly are broken

Asked by davidballano

Hello guys,

Im running into one issue with my 0.9.9 graphite installation, suddenly all the graphs that have maths on it have stopped working showing the broken graph icon, thats the error I'm getting when i copy paste the graph into a browser

I can't quite figure out what could be causing this. Anyone have any thoughts here? Thanks!

Traceback (most recent call last):
File "/usr/lib/python2.4/site-packages/django/core/handlers/", line 99, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "/opt/graphite/webapp/graphite/render/", line 105, in renderView
    seriesList = evaluateTarget(requestContext, target)
  File "/opt/graphite/webapp/graphite/render/", line 10, in evaluateTarget
    result = evaluateTokens(requestContext, tokens)
  File "/opt/graphite/webapp/graphite/render/", line 21, in evaluateTokens
    return evaluateTokens(requestContext, tokens.expression)
  File "/opt/graphite/webapp/graphite/render/", line 29, in evaluateTokens
    return func(requestContext, *args)
  File "/opt/graphite/webapp/graphite/render/", line 367, in scale = '.'.join(metric_pieces[n] for n in nodes)
NameError: global name 'nodes' is not defined

Question information

English Edit question
Graphite Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Michael Leinartas (mleinartas) said :

Hm, I'm not seeing code that lines up with the stacktrace in 0.9.9 or in trunk.. Are you sure you're running 0.9.9? Do you have any patches applied since then?

Revision history for this message
davidballano (dfernandez-4) said :

the problem has been solved, someone changed the code of /opt/graphite/webapp/graphite/render/ on the server and broke things.

replacing the file for the original one solved the problem.
thanks for you help.