files and directories in the rrd dir are not appearing in the webapp

Asked by Alex Dreyer on 2011-12-29

To ease our transition to graphite we're trying to continue using our current munin plugins with graphite as a front end.

Following the directions in the collectd section of the docs and symlinked a munin generared rrd file into a subdirectory of $GRAPHITE_ROOT/storage/rrd. that directory does not appear in the webapp.

I restarted the webapp and carbon and still nothing.

I deleted it and made a new dir in rrd/ and still nothing

I made a directory in whisper/ and it appeared.

I'm using ubuntu 10.04 and Python 2.6

Question information

Language:
English Edit question
Status:
Solved
For:
Graphite Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Leinartas
Solved:
2012-01-03
Last query:
2012-01-03
Last reply:
2012-01-01
Alex Dreyer (dutret) said : #1

I'm using graphite 0.9.9

Best Michael Leinartas (mleinartas) said : #2

Do you have the Python RRD bindings installed? On Lucid the package name is 'python-rrdtool'. If the binding load fails, RRD directory is skipped (silently, unfortunately).

Alex Dreyer (dutret) said : #3

thanks that worked.

Alex Dreyer (dutret) said : #4

Thanks Michael Leinartas, that solved my question.