No graphs after doing quick start guide

Asked by Gabe Harriman on 2010-10-01

Hello there

I ran through the quick startup guide and got it all to work, except when I load up the front end user interface, there are no graphs. The interface is beautiful, but there are broken images where I would think the graph should go.

I opened up the URL to the image file and noticed the django error below. Have you seen this before?

Thanks!

Gabe

MemoryError at /render/

Environment:

Request Method: GET
Request URL: http://ec2-184-72-180-200.compute-1.amazonaws.com:8080/render/?width=586&height=303&_salt=1285975334.848&title=gabe
Django Version: 1.2.3
Python Version: 2.6.5
Installed Applications:
['graphite.metrics',
 'graphite.render',
 'graphite.cli',
 'graphite.browser',
 'graphite.composer',
 'graphite.account',
 'graphite.whitelist',
 'django.contrib.auth',
 'django.contrib.sessions',
 'django.contrib.admin',
 'django.contrib.contenttypes']
Installed Middleware:
('django.middleware.common.CommonMiddleware',
 'django.middleware.gzip.GZipMiddleware',
 'django.contrib.sessions.middleware.SessionMiddleware',
 'django.contrib.auth.middleware.AuthenticationMiddleware')

Traceback:
File "/usr/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/core/handlers/base.py" in get_response
  100. response = callback(request, *callback_args, **callback_kwargs)
File "/opt/graphite/webapp/graphite/render/views.py" in renderView
  142. image = doImageRender(requestOptions['graphClass'], graphOptions)
File "/opt/graphite/webapp/graphite/render/views.py" in doImageRender
  299. img = graphClass(**graphOptions)
File "/opt/graphite/webapp/graphite/render/glyph.py" in __init__
  141. self.drawText("No Data", x, y, align='center')
File "/opt/graphite/webapp/graphite/render/glyph.py" in drawText
  201. extents = self.getExtents(text)
File "/opt/graphite/webapp/graphite/render/glyph.py" in getExtents
  173. F = self.ctx.font_extents()

Exception Type: MemoryError at /render/
Exception Value:

Question information

Language:
English Edit question
Status:
Solved
For:
Graphite Edit question
Assignee:
No assignee Edit question
Solved by:
Gabe Harriman
Solved:
2010-10-02
Last query:
2010-10-02
Last reply:

I found another thread with the same problem. I installed the bitmap-fonts and everything works now.

Ilya Zakreuski (zlj) said : #2

Hi Gabe,

I just wanted to add that installing bitstream-vera-fonts package for RPM-based systems should fix the issue too and also provide slightly better-looking graphs.

Cheers,
Ilya Zakreuski

That looks much better, thank you Ilya!

Kai Blin (kai-blin-biotech) said : #4

On current Ubuntu 13.04, there's no bitmap-fonts package, and this error keeps happening.