Launch problem on windows 8.1 64 bits

Asked by Gregoire

Hello, I've discovered Gourmet Recipe Manager on Linux. Everything worked fine but I had to move to a Windows computer recently.

I now have a Thinkpad X1 notebook with Windows 8.1 64 bits. The installation of Gourmet went fine but when I launch it it shows this error message:

http://postimg.org/image/47a9hhchd/5c3c465a/

(sorry the copy/paste does not work on the error window...)

I've installed previously python on my machine. Do not know if this is the problem (also there is no Bernie user on my laptop and python27 is not located on "Program Files" but directly on C:\Python27.

Do you have any idea of the problem?

Thanks

Gregoire

Question information

Language:
English Edit question
Status:
Answered
For:
Gourmet Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Bernhard Reiter (ockham-razor) said :
#1

Hi,

I'm Bernie ;-)

(Actually, while it's a bit annoying that programs frozen with cx_freeze spill details about the paths on the computer they were frozen on, those paths aren't any source of problems for the machine they're executed on, as the relevant libraries and even the Python interpreter are packed into the frozen binary.)

So apparently Gourmet just isn't finding its recipes.db database file. As I don't have any computer with Windows > 7 available to test, can you please try to locate if such a recipes.db file is present on your system? (It should've been created on first run, before Gourmet tries to load it.)

@Tom, do you have a Windows 8.1 computer to test on and/or experienced similar issues?

If you find it, you can try to run Gourmet from a command prompt with the --gourmet-directory parameter set to the folder that contains recipes.db.

Hope that helps. Unfortunately there could be a number of reasons for this issue, e.g. maybe related to UAC (user access control) -- did you install Gourmet as administrator/"for all users"?

Regards
Bernhard

Revision history for this message
Gregoire (gregle) said :
#2

Hi, thanks for your answer.

I tried to uninstall/reinstall Gourmet but there is no choice "for all users". I am admin of my computer so I guess the default installation is for everyone.

As for recipes.db file, I cant find it through the search function of Windows. I have a "recipe.dtd" in the root directory of Gourmet Recipe Manager and some "recipemanager.py" and "recipeidentifier.py" in Gourmet Recipe Manager/Lib/site-packages/gourmet and other "recipemerger", "recipeindex" etc.

Should I take a recipes.db file somewhere and just copy/paste it inside my directory? (if so where can I find it?)

Thanks

Gregoire

Revision history for this message
Bernhard Reiter (ockham-razor) said :
#3

I guess what's crucial is to find out where Gourmet expects that recipes.db file on your system (or where it wants to create it on first run, respectively). It comes in handy that you have Python installed.

Please run the following in Python, and tell me the value it yields for the APPDATA folder:

import os
APPDATA = os.environ.get('APPDATA',None)

You could also just check the value of that APPDATA environment variable in another way, but I guess its best to use Python, as Gourmet is also programmed in Python -- just in case there's some Python-specific issue. (BTW that folder is probably hidden, but normally it should contain a subfolder named gourmet as soon as gourmet has run for the first time.)

Revision history for this message
Gregoire (gregle) said :
#4

Hi, my APPDATA is:
'C:\\Users\\Gr\xe9goire\\AppData\\Roaming'
(my username is Grégoire but I guess the accent is modified into \xe9. Dont know if the problem can come from here)

Thanks for your help

Revision history for this message
Bernhard Reiter (ockham-razor) said :
#5

Well, that does sound like a possible reason indeed. Can you create a test user account without any diacritics in its name and test gourmet with that?

Revision history for this message
Gregoire (gregle) said :
#6

Hi, indeed it seems to work with another account name with no diacritics.

Do you think the problem could be fixed in the next version? It seems kind of a pain to rename the default user folder in Windows...

Thanks for your help

Revision history for this message
Bernhard Reiter (ockham-razor) said :
#18

Yeah, I absolutely need to fix this. Thanks for helping diagnose it!

Revision history for this message
Gregoire (gregle) said :
#19

You're welcome, glad I can help improve this great software.

Revision history for this message
Thomas Hinkle (tmhinkle) said :
#20

I'm late to the thread but I can confirmI've tested gourmet on 8.1 without
any issues so the diacritics may be the issue.
On Aug 16, 2014 4:56 PM, "Bernhard Reiter" <
<email address hidden>> wrote:

> Question #253001 on Gourmet changed:
> https://answers.launchpad.net/gourmet/+question/253001
>
> Status: Open => Needs information
>
> Bernhard Reiter requested more information:
> Well, that does sound like a possible reason indeed. Can you create a
> test user account without any diacritics in its name and test gourmet
> with that?
>
> --
> You received this question notification because you are a member of
> Gourmet Recipe Manager, which is an answer contact for Gourmet.
>

Revision history for this message
Bernhard Reiter (ockham-razor) said :
#21

Can you help with this problem?

Provide an answer of your own, or ask Gregoire for more information if necessary.

To post a message you must log in.