database issues (sqlite)

Asked by Will Blaylock on 2013-11-21

I have been using gourmet for a long time, and have kept several databases for several purposes, work, family, personal, etc.

Last time I compiled gourmet (version 16.0<forgotten>) I had to go through and change the version number in several of the databases to get them to load, and everything worked awesomly afterward.

I just compiled from the git, pulled 2013/11/18 and can not load any of my databases except the default database.

I may well be misunderstanding something, but that is what questions are for :)

still getting this error (and can include the rest if that is helpful)

sqlalchemy.exc.OperationalError: (OperationalError) no such column: pantry.id u'SELECT pantry.id, pantry.ingkey, pantry.pantry \nFROM pantry' ()

which was solved by changing version number before, and it upgraded the database automagically.

I am further unsure why the last upgrade did not follow, and can go back to backups if needed. All I have done for some time is print recipes, no additions.

Question information

Language:
English Edit question
Status:
Solved
For:
Gourmet Edit question
Assignee:
No assignee Edit question
Solved by:
Will Blaylock
Solved:
Last query:
Last reply:
Will Blaylock (wblalok) said : #1

very interesting:

if I remove the default recipies.db adn replace it with one of the others, all is well apparently.

changing the version number to 0.15.9 does the job nicely.