not working with a .gpx of garmin with points

Asked by Fernando on 2017-04-26

I got the message
could not open: file.gpx

with this .gpx file with points:

<?xml version="1.0" encoding="UTF-8" standalone="no" ?><gpx xmlns="http://www.topografix.com/GPX/1/1" xmlns:gpxx="http://www.garmin.com/xmlschemas/GpxExtensions/v3" xmlns:wptx1="http://www.garmin.com/xmlschemas/WaypointExtension/v1" xmlns:gpxtpx="http://www.garmin.com/xmlschemas/TrackPointExtension/v1" creator="Oregon 550" version="1.1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.topografix.com/GPX/1/1 http://www.topografix.com/GPX/1/1/gpx.xsd http://www.garmin.com/xmlschemas/GpxExtensions/v3 http://www8.garmin.com/xmlschemas/GpxExtensionsv3.xsd http://www.garmin.com/xmlschemas/WaypointExtension/v1 http://www8.garmin.com/xmlschemas/WaypointExtensionv1.xsd http://www.garmin.com/xmlschemas/TrackPointExtension/v1 http://www.garmin.com/xmlschemas/TrackPointExtensionv1.xsd"><metadata><link href="http://www.garmin.com"><text>Garmin International</text></link><time>2016-10-10T10:47:01Z</time></metadata><wpt lat="14.164191" lon="-47.790581"><ele>741.985596</ele><time>2016-10-10T10:47:01Z</time><name>021</name><sym>Flag, Blue</sym></wpt><wpt lat="-16.603090" lon="9.260296"><ele>742.756042</ele><time>2016-10-10T10:47:09Z</time><name>022</name><sym>Flag, Blue</sym></wpt></gpx>

Question information

Language:
English Edit question
Status:
Answered
For:
GottenGeography Edit question
Assignee:
No assignee Edit question
Last query:
2017-04-26
Last reply:
2017-05-07
Fudaraku (laszlo-burgmann) said : #1

I had a similar problem. By reading the code I understood that gottengeography requires a gpx file with tracks. Ie, you must have trkseg and trkpt tags instead of wpt tags.

My input is my Google location history converted by location_history_json_converter.py. I need to use the gpxtracks format instead of plain gpx. With that gottengeography works like a charm.

Can you help with this problem?

Provide an answer of your own, or ask Fernando for more information if necessary.

To post a message you must log in.