Gnomenu doesn't work anymore after update to 2.1 version

Asked by TheEdgeOfForever on 2009-12-15

I've tried to update gnomenu from 1.9.9 version to 2.1 one. Installation process has gone fine, but when I try to launch gnomenu, it doesn't work. System replies with the following error message:
"GnoMenu could not be loaded. An internal error occurred and the applet could not be loaded."

Then I launch the command "sudo run-in-window" in a terminal, but I get: "sh: /usr/lib/gnomenu/ Permission denied".

So I've decided to come back to 1.9.9 version...but nothing changes. I can't use gnomenu anymore :(
Any help?

PS: I use ubuntu 8.04 LTS

Question information

English Edit question
GnoMenu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
technoshaun (shaun-marolf) said : #1

Possible reasons: 8.04 does not have the available dependencies or correct versions. Somehow your permission to run /usr/share/bin/ is incorrect and using the sudo command (or gksu nautilus) should be reset to allow it to be executable and/or executable by users. Lastly one of the dependencies has an incorrect permission.

So, there is no way to solve my problem and to install gnomenu latest version?
If not, how can I do to restore previous version (1.9.9 works correctly in my ubuntu)?
Thank you

Helder Fraga (whise) said : #3

set executable permitions to /usr/lib/gnomenu/

I've set executable permission to the file you told me (chmod 755 nothing changes.
However the command sudo run-in-window makes gnomenu start... :S

I've set executable permission to the folder /usr/lib/gnomenu and to all its's what I get in a terminal running run-in-window:

Traceback (most recent call last):
  File "/usr/lib/gnomenu/", line 67, in <module>
  File "/usr/lib/python2.5/logging/", line 1240, in basicConfig
    hdlr = FileHandler(filename, mode)
  File "/usr/lib/python2.5/logging/", line 770, in __init__
    stream = open(filename, mode)
IOError: [Errno 13] Permesso negato: '/home/paolo/.gnomenu/.GnoMenulog.txt'

What can I do to resolve this problem?

PS: gnomenu starts correctly if I launch it as super user...

The Techie (the-techie) said : #6

Try to do the same for the .gnomenu folder and see what happens (somehow your permissions are screwed).

Finally I've solved my problem...I've changed permission to all gnomenu's folder including the themes folder. Now it works good! ;)
Thank you