Menu Items appear twice and can't be removed

Asked by mindseye1 on 2009-10-08

After installing Gnomenu from the 1.9.6 deb package in Ubuntu Karmic, I also installed a few games (Frozen-Bubble and KMines). At some point I noticed that the icons for these games were appearing in the main section of the menu as well as under the Games sub-menu. I've tried many times to figure out how they got there, but I can't find any files that list them there. When I go to "Edit Menus" screen they only appear under the Games sub-menu. When I look in the regular Gnome Menu they only appear under the Games sub-menu. But for some reason in Gnomenu they appear right in the main menu! The only way I can make them go away is by uninstalling the games! I've also tried completely uninstalling and reinstalling the Gnomenu package as well; no luck. Can anyone give me a clue as to how I can get rid of these menu items and only have them in the sub-menus where they belong?

Question information

Language:
English Edit question
Status:
Solved
For:
GnoMenu Edit question
Assignee:
No assignee Edit question
Solved by:
mindseye1
Solved:
2009-10-11
Last query:
2009-10-11
Last reply:
2009-10-11
technoshaun (shaun-marolf) said : #1

What theme are you using? Does this occur with another theme? Have you tried GnoMenu 1.9.9 to see if this problem is corrected?

mindseye1 (mindseye11) said : #2

I was using the Windows 7 theme, but any theme that I switch to also has this issue. I have not tried 1.9.9 because there is no .deb package for it yet. I've searched the whole filesystem for .menu files that I could manually edit, but I haven't found any yet besides the standard one. Could it possibly be combining a Gnome .menu file and a KDE .menu file somehow? Where would I find the KDE menu files to check this?

technoshaun (shaun-marolf) said : #3

You can get the 1.9.9 debs via launchpad, add these lines to /etc/apt/sources.list:

deb http://ppa.launchpad.net/gnomenu-team/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/gnomenu-team/ppa/ubuntu jaunty main

Then run this command to get authentication key:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 95B47D2A

mindseye1 (mindseye11) said : #4

Well I tried the upgrade to 1.9.9 but still no luck. I've got some more observations though. It seems it is only games that appear in the main menu. I just installed an internet application and the menu item was put in the proper internet subdirectory. It also seems like Gnomenu is not using the same source as the Gnome menu. For example, in the Gnome menu, the "System Tools" group id disabled, but it is visible in my Gnomenu.

What are all of the source files that Gnomenu uses to compile its menu items?

mindseye1 (mindseye11) said : #5

Is there maybe a cache somewhere that Gnomenu uses to build its menu items? I noticed that when I enabled something in the "System Tools" group to compare it to the regular Gnome menu, and the disabled that item again to return to normal, that item is also still stuck now in the "System Tools" group of Gnomenu.

technoshaun (shaun-marolf) said : #6

GnoMenu uses the same files as all the other Gnome Menu Apps such as Main Gnome Menu so I am not sure as to why you are getting double entries. I have known there to be issues if one uses KDE but AFIK that was supposed to have been fixed with the KDE 4.X series.

mindseye1 (mindseye11) said : #7

So do you happen to know what KDE files I should check to look for these entries? Should I move this over to the bug database?

mindseye1 (mindseye11) said : #8

Finally got it back to normal. Deleted ~/.config/menus directory; deleted ~/.local/desktop-directories; removed all game sub-directories (action games, block games, etc...) from /etc/xdg/menus/applications.menu, and now I have my game icons back to only being in the Game sub-folder. Thanks for the help!