Panel encountered a Problem while loading OAFIID: GNOME_GnoMenu

Asked by Linuxexperte on 2009-09-03

Icannot add GnoMenu to my panel although I have phython 2.6 installed. It alsways comes with the same Error Message
as in the Title.
How to solve this issue?

Thanks for your help.


Question information

English Edit question
GnoMenu Edit question
No assignee Edit question
Last query:
Last reply:

This question was reopened

technoshaun (shaun-marolf) said : #1

What version of Gnome Panel are you using? What Linux distribution is this happening in?

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

Linuxexperte (andrea-koeth) said : #3

@ technoshaun:
hello and sorry that I didn't answer for such a long time. I had been busy. But now I will answer your questions.

I am using Karmic Koala (Ubuntu 9.10) and my Panel is version 2.28.0.

I wanted to install the GnoMenu-Applet and every time I try, I get the message about this problem.

Perhaps you now an anwer or a soluton for this problem? I will try on and see if this is happening still. I will come back to you.


Linuxexperte (andrea-koeth) said : #4

@ technoshaun:
I have a new Problem with this this. I have now downloaded the gnomenu-1.9.9.tar.gz. Then I changed it into an .deb-Package via alien. Then I tried to install this .deb-Package. But sudenly i got the following Error-Message:

dpkg Kann Dateideskriptorflags für "<Dateideskriptor für Paketstatus und Fortschritt>" nicht lesen: Bad file descriptor

The Package didn't install at all.

How to go on now?

I would be thankful, ifyou could help me with this.


technoshaun (shaun-marolf) said : #5

Use the PPA and get the DEB package

Add this line to /etc/apt/sources.list:

"deb jaunty main"

Then run the following command to get gpg key:

"sudo apt-key adv --keyserver --recv-keys 95B47D2A"

Then run:

"sudo apt-get update && sudo apt-get install gnomenu"

Linuxexperte (andrea-koeth) said : #6

@ technoshaun:
I just received your reply with the instruction.
But in executing your instruction, the Terminal gave me this error-message as I tried to collect the key.

andrea@andrea-desktop:~$ sudo apt-key adv --keyserver --recv-keys 95B47D2A
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --keyserver --recv-keys 95B47D2A
gpg: Schlüssel 95B47D2A von hkp Server anfordern
gpg: Schlüsselserver hat das Zeitlimit überschritten
gpg: Empfangen vom Schlüsselserver fehlgeschlagen: Schlüsselserverfehler

Is this en error because fo the server or is it again something inside the distribution itself? Or is it anything else?

Could you please be so kind to reply?

Thank you in advance for your reply.


technoshaun (shaun-marolf) said : #7

Launchpad server does that more often than I like. Just keep trying every couple of hours or so.

Linuxexperte (andrea-koeth) said : #8

@ technoshaun:
I wanted to let you know, that I was able to import this key successfully just a minute ago. Thank you that this was an error of this launchpad server. It seems, that launchpad server is not so high frequented at weekends.

So it seems to be better to do importing fo keys on weekends like saturday or sundy.


Linuxexperte (andrea-koeth) said : #9

@ technoshaun:

I have one more question to the GnoMenu.
I have successfully installed the Menu and some Themes also. But hwen I open the Menu, then the Icons are not displayed beside the Names of the programmes, although I activated the Icons (I have also downloaded some icon-Themes from These Icon-Themes were also successfully installed.

So I would like to know, how to do it, that the Icons are correctly displayed.

Thank you for your answer.


technoshaun (shaun-marolf) said : #10

technoshaun suggests this article as an answer to your question:
FAQ #283: “No Icons in GnoMenu Menu Panel”.

technoshaun (shaun-marolf) said : #11

OP has not replied since last post OAFIID Issue in Ubuntu still under active investigation as a bug