Gnomenu cant use synaptic

Asked by tiina on 2009-08-24

when i open synaptic from gnomenu 1.9.9

"Starting without administrative privileges
You will not be able to apply any changes. But you can still export the marked changes or create a download script for them"

works fine from "normal" gnome menu
running jaunty

Question information

Language:
English Edit question
Status:
Solved
For:
GnoMenu Edit question
Assignee:
No assignee Edit question
Last query:
2009-08-24
Last reply:
2009-11-06

This question was reopened

technoshaun (shaun-marolf) said : #1

Make sure that when GnoMenu calls synaptic that gksu is at the front of the entry. To do this simply use the Gnome Edit Menu option or GnoMenu preferences, (depending on where you are calling synaptic from on the menu) and check the command option.

tiina (tukevampi) said : #2

done..still a problem, package manager button on the left side now works but when i use
"system tools -> synaptic package manager" i get the same message "starting without admi...."?!?!?

technoshaun (shaun-marolf) said : #3

Right click on the GnoMenu button and select "Edit Menus" then select the "System" sub-menu. Then select "Administration" then select "Synaptic Package Manager" and click the Properties button. The command line should be "gksu --description /usr/share/applications/synaptic.desktop /usr/sbin/synaptic"

Hope that helps

technoshaun (shaun-marolf) said : #4

GnoMenu issue was solved. Gave OP extra information beyond GnoMenu.