file preference bug question

Asked by davidpribis on 2009-07-30

  I know there is a bug report and a fix for this. I'm looking for the fix. When I select Music or Video, the home folder opens. What is odd is that I set up a second user account on my system, for some visitors. I added the Gnomenu app to the panel, and when I clicked on Music, the music file opened. I loged out and in to my account, clicked on Music and the Home folder opened. Now....what's that all about.....tks Gnomenu 1.9.9 on Ubuntu Jaunty.

Question information

Language:
English Edit question
Status:
Solved
For:
GnoMenu Edit question
Assignee:
No assignee Edit question
Solved by:
davidpribis
Solved:
2009-07-30
Last query:
2009-07-30
Last reply:
2009-07-30
technoshaun (shaun-marolf) said : #1

This isn't a bug per say s it is a issue with the XML code settings in the theme you are using and your actual file structure under the Home directory.

in the /usr/share/gnomenu/Themes/Menu directory open the directory that corresponds to your theme name and right click in the themedata.xml file and select "Open With" and select gedit.

Now make sure of the following:

That the Directory GnoMenu is told to open exists;
     If only the command "Videos" is used then the directory Videos must exist in the user's home directory.
     If a path is used then ensure that that path is correct (example: ~/documents/pictures)

That GnoMenu is using the correct Command:
     Some themes use "Games" as the command instead of Videos or Music, etcetera.

If you need to fix any of the above use "gksu gedit /usr/share/gnomenu/Themes/Menu/themename]/themedata.xml" and make the necessary corrections.

davidpribis (treetopper73) said : #2

I checked the xml settings and found they were compliant. I set up another account and the problem did not reoccur. Not sure what happened, so I tried it out on a fresh install, and the problem did not occur there as well. So I solved my problem by moving to the new, working account. I assume there was a system setting issue, I gconf-edit all day long (its fun). Good enough for me. I'll keep trying to make the problem happen again, thats what I do for fun.....break things. Tks for you response, it was very timely.