Gnomenu Docky Integration

Asked by Morgen on 2010-08-10

After installing GnoMenu the helper is not availible in the Docky Menu. I have checked that the files are located in "/usr/share/dockmanager/scripts/". I have found several sites that indicate this issue was resolved for most but I have not been able to get this resolved.

Linux Mint 9 (64 bit)
GnoMenu 2.9 (via PPA)
Docky 2.1 (via PPA)

I have read this question: https://answers.launchpad.net/gnomenu/+question/117469

The information provided does not appear to solve the problem.

Thanks for any help.

Question information

Language:
English Edit question
Status:
Open
For:
GnoMenu Edit question
Assignee:
No assignee Edit question
Last query:
2010-08-12
Last reply:
2010-08-12
technoshaun (shaun-marolf) said : #1

Make sure that all dependencies for both GnoMenu and Docky are met since you installed both from the PPA, then install all the recommended packages as well. The 64 bit systems still aren't as complete as the 32 bit counterparts, which is why I stay with the 32 bit systems on my desktop. Question 117469 was never completely resolved as the OP never did get back with me.

Morgen (jab-mail-business) said : #2

GnoMenu and Docky both work flawlessly on their own so it would appear that the dependencies have been met, how would I go about verifying this?

Just to clarify the PPA's that I have installed from:

http://ppa.launchpad.net/gnomenu-team/ppa/ubuntu lucid main
http://ppa.launchpad.net/docky-core/stable/ubuntu lucid main

As for the 64-bit, I understand what you are saying but I use 64-bit in the hope that adoption drives development. I have 6 gigs of RAM, 2 of which are useless without a 64-bit OS.

Thanks for the help.

technoshaun (shaun-marolf) said : #3

List of dependencies and recommended files from the GnoMenu Guide. As for Docky you will probably have to check their documentation.

-----------------
2.1 Dependencies:
-----------------

* Depends:

python
python-xdg
python-cairo
python-gtk2 - that includes pygtk and python-pango
python-gnomeapplet *** necessary only when running on gnome-panel *** - or in some distros "python gnome desktop"
python-xml - may be needed in older distributions (eg: ubuntu before karmic)

* Recomends:

gmenu - will use this instead of xdg if it is installed
python-numpy - for gtk theme colors and some tab effects
python-gconf - or in some distros "python gnome"
python-keybinder or python-xlib - for keybinding
gettext - for translations
zeitgeist

WARNING - In some distribution the packages names may not be the same.(this is the Ubuntu example)

Since you are using 64 Bit make sure to follow this:

--------------------
2.2.5 64 bit install
--------------------

In order to install gnomenu on 64 bit systems you have to manually edit some files

To convert gnomenu to 64 bit operation. I use the following, which works
for me and does not give any error message:-

    1. Open gnomenu->Makefile then, change all '/lib' text with
       '/lib64'
    2. Repeat for 'setup.py'
    3. Finally open gnomenu->src and rename folder 'lib' to lib64

Thanks to Collin Mills

Finally for using GnoMenu in Docky:

---------------------------
2.2.6 Docky helper / Applet install
---------------------------

1. Just install GnoMenu normally, with sudo make install
2. Activate the GnoMenu helper in Docky menu
3. Restart Docky

Hope all this helps.

Morgen (jab-mail-business) said : #4

So I have checked all the dependencies and recommended software. All were installed except python-numpy. Installing python-numpy did not resolve the issue. When I check my file system '/lib64' is just a link to '/lib', I don't see how changing these will make a difference when one is just a link to the other.

The thing I notice is that the GnoMenu helper is installed to '/usr/share/dockmanager/scripts' but last I checked Docky looks for helpers in '/usr/share/docky/helpers'. In fact if I move the GnoMenu files to '/usr/share/docky/helpers', then GnoMenu shows up in the helper menu but of course it does not work since it is not coded for this location.

Again Docky works, GnoMenu works. It's just that GnoMenu does not show up in the Docky helper menu.

Thanks again for any help.

technoshaun (shaun-marolf) said : #5

Well at least we're getting somewhere. The last time I tried to resolve this the person never replied to me so I never could. With your help we just may get this done.

The issue here seems to be the differences between the 32 and 64 bit file structure and locations. If this is the case then its just a matter of changing the location in GnoMenu's code and reinstalling it. This, however, will require you to use the tar ball file from the GnoMenu trunk. You will need to install bzr (sudo apt-get install bzr) to do this then run the command: bzr branch lp:gnomenu to get the trunk. I shall see if I can find the line that needs to be changed for your needs.

Morgen (jab-mail-business) said : #6

I followed your instructions so far. I have the bzr trunk of GnoMenu and tried copying over the '/gnomenu/src/share/dockmanager/metadata' and '/gnomenu/src/share/dockmanager/scripts/*' as suggested on this cached webupd8.com post:

http://www.mybookmarks.ro/linux/gnomenu-2-9-released-with-docky-support-and-a-new-theme-especially-designed-for-docks/

Interestingly the PPA install did not create the metadata folder or contained file but unfortunately simply copying it over did not solve the issue.

technoshaun (shaun-marolf) said : #7

Okay here is what I need you to do. Remove GnoMenu using Synaptic or whatever method you prefer. The DEB package isn't going to work in this case. Using the tar ball file, unpack it (which I assume you already have) and then from the unpacked top level directory run "sudo make install" then follow the directions from http://www.mybookmarks.ro/linux/gnomenu-2-9-released-with-docky-support-and-a-new-theme-especially-designed-for-docks/

Morgen (jab-mail-business) said : #8

Sorry Shaun, it still does not appear to work. I completely removed the package via synaptic. Installed if from the bzr files downloaded. Currently synaptic shows that it is not installed. GnoMenu is installed though and does work but does not show up in Docky. In case it is relevant I am running Docky 2.0.6 bzr r1346. If there is any additional information you need or other ideas you would like me to try out just let me know. Thanks for your patience.

technoshaun (shaun-marolf) said : #9

Okay lets do another check on the required files and recommended files. Since you did a complete removal some of them may have been flagged for removal as well. I'm hoping for the best here at this point. I know it works with 32 bit systems but if this doesn't do it then all we can do is hope Helder gets his laptop that burned out replaced soon and returns to fix this. If it doesn't work I'll turn this into a bug report for him so he knows that there is an issue with 64 bit systems and Docky integration.

Morgen (jab-mail-business) said : #10

Just checked the dependencies, no changes. Looks like a bug on 64-bit systems. Thanks for all your help. If you need any additional information to help trouble shoot this just let know. Thanks again.

Can you help with this problem?

Provide an answer of your own, or ask Morgen for more information if necessary.

To post a message you must log in.