Can we disable Always On Top?

Asked by J.M. "Peng" Hardin on 2010-04-08

I'm loving the GNOME Media Player (GMP) so much I've made it my default video media player, but it's annoying that I always have to manually disable the Always On Top window setting. Often when I want to see a video I don't have that as my primary task at the moment and I'd love to be able to launch a video, switch to another open window and be able to use all of that window without having to first tell GMP that I don't want it on the top.

I know that this change in the settings keeps me from seeing part of the video (often just a corner of it) but I'm completely alright with that and I wish I didn't have to take this extra step every time I launch GMP.

1. While working in another app (such as the Chromium web browser) make a choice to watch a video. Sometimes this is a video that I have just downloaded.
2a. Find the video in Nautilus and choose to open the file in GMP.
   - or -
2b. Open the video file from the Chromium download bar (after telling Ubuntu that I want to open MP4, Ogg Thora, and other video content in GMP by default).is
3. Once the file is opened in GMP click on the menu button on the title bar and deselect Always On Top.
4. Switch back to my original application window. The video continues to play with the GMP window slightly obscured by the newly selected window.

Delete step 3 completely, allowing the window selected in step 4 to be 100% usable without GMP blocking any of the window.

Question information

English Edit question
GNOME Media Player Edit question
Bilal Akhtar Edit question
Solved by:
J.M. "Peng" Hardin
Last query:
Last reply:
Bilal Akhtar (bilalakhtar) said : #1

So you only want Step 3 to go away?
Ok, I will work on that. Thanks for the feedback on GMP.

That would be a great option to be able to set. Thanks.

Bilal Akhtar (bilalakhtar) said : #3

This bug has been fixed in revision 87. I have pushed the packages to the PPA, and should be built and ready within an hour.

YES! Thank you. I'm marking the question answered.