Gnome activity journal shows no entries

Asked by Jerry Chong on 2010-01-29

Not quite sure if this is a bug, or merely a problem with my setup, so I thought I'd check here first. :)

Was trying out Gnome Activity Journal 0.3.2 from the PPA on Karmic, with Zeitgeist 0.3.2. Oddly, the journal isn't showing any entries at all. I haven't tried programmatically querying Zeitgeist via dbus to see if it's actually returning anything, but a quick check at .local/share/zeitgeist does show a 50mb database.sqlite. Zeitgeist has been installed and run at startup since 0.1, so I'm not sure if it's due to legacy database schema/incompatibilities.

Question information

Language:
English Edit question
Status:
Solved
For:
GNOME Activity Journal Edit question
Assignee:
No assignee Edit question
Solved by:
Jerry Chong
Solved:
2010-01-30
Last query:
2010-01-30
Last reply:
2010-01-29
Siegfried Gevatter (rainct) said : #1

Hi,

Thank you for your feedback.

The file "database.sqlite" is from Zeitgeist 0.2.x and is no longer used; with Zeitgeist 0.3.x it was renamed to "activity.sqlite" (and the used table structure has also changed significantly).

Some things I'd suggest to try to find the problem:
 - Check the content of ~/.local/share/zeitgeist/activity.sqlite
 - Ensure that the zeitgeist-datahub package is installed, and not only zeitgeist-core.
 - Run "zeitgeist-daemon --replace" from a terminal and check the log output for errors. (You could also run the datahub as a different process, by running "zeitgeist-daemon --replace --no-passive-loggers" and then in a separate terminal window, "zeitgeist-datahub", so that their output isn't all mixed together).

Jerry Chong (zanglang) said : #2

Oh, thanks. :) Just noticed that there was a new zeitgeist metapackage that pulled in zeitgeist-datahub, and judging by the logs zeitgeist is correctly capturing events now.