GAJ will not launch

Asked by JamesHFox on 2010-12-08

Nothing happens when I try to launch GAJ. I ran it from terminal and got these results (sorry, not sure if the entire piece is relevant or just the last line):

Traceback (most recent call last):
  File "/usr/bin/gnome-activity-journal", line 92, in <module>
    from src.main import Portal
  File "/usr/share/gnome-activity-journal/src/main.py", line 30, in <module>
    from widgets import *
  File "/usr/share/gnome-activity-journal/src/widgets.py", line 42, in <module>
    from sources import Source, SUPPORTED_SOURCES
  File "/usr/share/gnome-activity-journal/src/sources.py", line 41, in <module>
    Interpretation.MUSIC.uri: Source(Interpretation.MUSIC, "gnome-mime-audio", _("Worked with Audio"), _("Worked with Audio")),
  File "/usr/lib/pymodules/python2.6/zeitgeist/datamodel.py", line 185, in __getattr__
    raise AttributeError("'%s' object has no attribute '%s'" %(self.__class__.__name__, name))
AttributeError: 'Symbol' object has no attribute 'MUSIC'

Question information

Language:
English Edit question
Status:
Answered
For:
GNOME Activity Journal Edit question
Assignee:
No assignee Edit question
Last query:
2010-12-08
Last reply:
2011-01-06

This question was originally filed as bug #687606.

JamesHFox (jhowardfox) said : #1

Is there anything I could add to help get this resolved? This is probably the second bug I've ever reported so I apologize if it's lacking the necessary details, but I'm happy to provide whatever else is needed. I'm really impressed with the potential that GAJ and Zeitgeist have, but so far I've been unable to utilize them in any way. (For example, neither Synapse or Docky are able to implement their Zeitgeist capabilities.)
Thanks,
James

Siegfried Gevatter (rainct) said : #2

This is caused because you have incompatible versions of Zeitgeist and GNOME Activity Journal installed.

Siegfried Gevatter (rainct) said : #3

Hey James,

This is caused because you're using incompatible versions of Zeitgeist and GNOME Activity Journal. Please ensure that you have installed the latest versions of both, either from the same official Ubuntu repository (preferably Maverick main) or from our PPA (https://launchpad.net/~zeitgeist/+archive/ppa).

Can you help with this problem?

Provide an answer of your own, or ask JamesHFox for more information if necessary.

To post a message you must log in.