GNOME Activity Journal

problem in tracking activities in GAJ

Asked by doxao0710 on 2010-05-15

i hav installed the latest zeitgeist and GAJ from synastic package in ubuntu lucid

i spend most of the time listening to music (by rhythmbox and sometimes banshee) and surfing webs (using chrome) in my ubuntu machine. However, the GAJ doesnt record tracks that i played as well as webs that i visited. More over, when i open my pic using viewnior then move to the next pics by clicking the left/right button, GAJ only records the 1st pic that i 1st open in nautilus. As a result most of the time i open GAJ, it shows nothing but files that i opened (from nautilus) which are very little and do not reflect fully my activities. So what can i do to allow GAJ to record all of my activities?

Question information

Language:
English Edit question
Status:
Answered
For:
GNOME Activity Journal Edit question
Assignee:
No assignee Edit question
Last query:
2010-05-15
Last reply:
2011-04-29
Randal Barlow (email-tehk) said : #1

You need to install data sources for applications. Right now you are only logging events from recently-used. Unfortunately it is not as easy as using the latest revision of zeitgeist and dataproviders since they switched to a new ontology. So you will need revision 38(or possibly lower) of zeitgeist-dataproviders/trunk and the latest zeitgeist release(not trunk) 0.3.3.1.

Those version requirements should be removed when Journal is updated to the new ontology, but that is delayed until the zeitgeist developers create a migration script from their old ontology to the new one.

links:
https://code.launchpad.net/~zeitgeist-dataproviders/zeitgeist-dataproviders/trunk

It seems current revision of zeitgeist-dataproviders is 124.
Zeitgeist current version on Ubuntu is is 0.5.2.

However, I still have this problem.
Is there any update about how to solve this problem ?
Thanks,

Stefano Candori (cando) said : #3

Last GAJ version is 0.6, you can try to upgrade to it.
Your zeitgeist-dataproviders are updated: are you sure that, e.g rhytmbox has the zeitgeist plugin activated??? (same for chrome/firefox and so on...).

Try this:
- open a terminal and type " zeitgeist-daemon --replace"
- listen to music or surf with chrome/firefox with the Zeitgeist plugin enabled

Result: In the terminal you should see an output similar to " Inserted 1 events...."

Can you help with this problem?

Provide an answer of your own, or ask doxao0710 for more information if necessary.

To post a message you must log in.